Closed Bug 1463498 Opened 2 years ago Closed 2 years ago

JavaScript error: resource://devtools/shared/base-loader.js -> resource://devtools/client/framework/toolbox-options.js, line 228: TypeError: this.telemetry is undefined

Categories

(DevTools :: Framework, defect)

defect
Not set

Tracking

(firefox62 fixed)

RESOLVED FIXED
Firefox 62
Tracking Status
firefox62 --- fixed

People

(Reporter: yzen, Assigned: yzen)

Details

Attachments

(1 file)

JavaScript error: resource://devtools/shared/base-loader.js -> resource://devtools/client/framework/toolbox-options.js, line 228: TypeError: this.telemetry is undefined happens because this is not set to OptionsPanel in the scope of the listener.
Regression from bug 1458208
Attached patch 1463498 patchSplinter Review
Attachment #8979677 - Flags: review?(mratcliffe)
Attachment #8979677 - Flags: review?(mratcliffe) → review+
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Keywords: checkin-needed
OS: Unspecified → All
Hardware: Unspecified → All
Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/898c5c1920bd
fixing this.telemetry is undefined error in toolbox-options.js. r=jdescottes
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/898c5c1920bd
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.