Remove browser.startup.homepage from firefox-l10n.js

NEW
Unassigned

Status

()

enhancement
P3
normal
11 months ago
9 months ago

People

(Reporter: flod, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox62 affected)

Details

(Reporter)

Description

11 months ago
As part of the move to shipping one Firefox with all locales, we need to eliminate firefox-l10n.js.

Currently zh-CN sets browser.startup.homepage in firefox-l10n.js, to load a URL from chrome://browser/locale/browser.properties

https://dxr.mozilla.org/l10n-central/rev/e73d39ca7cb5cc000ef519078c5a6c7d50d05d83/zh-CN/browser/firefox-l10n.js

This is brittle, and requires ad-hoc workarounds in localization tools to avoid losing that string.
(Reporter)

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 721211

Comment 2

11 months ago
I think there's a separate issue for this bug which is why we still allow china to have their own homepage. We should be switching them to Activity Stream.

MozillaOnline does their own repack. We control the one that comes from our website.
(Reporter)

Comment 3

9 months ago
Reopening, since bug 721211 made it possible to move this to a standard preference. Technically, we can do this in 65 (because of cross-channel), but comment 2 needs an answer.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

9 months ago
Status: REOPENED → NEW
Blocks: 1365426
Flags: needinfo?(francesco.lodolo)
Priority: -- → P3
Flags: needinfo?(francesco.lodolo)
You need to log in before you can comment on or make changes to this bug.