description list with small font in table ignores dd tags

RESOLVED DUPLICATE of bug 117738

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 117738
16 years ago
15 years ago

People

(Reporter: Panu Tuominen, Assigned: karnaze (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051006

When a description list (with <DT>s and <DD>s) is put inside <SMALL> and
</SMALL> tags and everything this is put in a TABLE cell, the description list
is shown incorrectly (both in quirks & standards mode).

Removing the SMALL tags changes the list appearance heavily.

Reproducible: Always
Steps to Reproduce:
1. Open a HTML page containing a description list with small font in a table cell.
2. Note the different (correct?) layout if the <SMALL> & </SMALL> tags are deleted.


Actual Results:  <DT>Term<DD>Description will be shown as:

TermDescription

Expected Results:  I guess <DT>Term<DD>Description should be shown as:

Term
        Description

HTML example that fails:

<HTML>
<BODY>

<TABLE>
<TR>
<TD>

<SMALL>
<DL>
<DT>Term<DD>Description
</DL>
</SMALL>

</TD>
</TR>
</TABLE>

</BODY>
</HTML>
(Reporter)

Updated

16 years ago
Component: HTMLTables → Layout

Comment 1

16 years ago
Created attachment 85144 [details]
the short html example from the reporter

See also the bug with 2002052508 on win95

Comment 2

16 years ago
Reporter: As a work around please use also the end tags !!

So write

<SMALL>
<DL>
<DT>Term</DT><DD>Description</DD>
</DL>
</SMALL>

The end tag are optional but looks like they are needed.

http://www.w3.org/TR/html4/struct/lists.html#h-10.3
it's there, yes...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 95 → All
(Reporter)

Comment 4

15 years ago
Created attachment 94437 [details]
Description list containing a huge comment

Just one test case more: Small-font description lists fail in tables even if
closing tags </DT> and </DD> are used. Just insert enought items into the list
-or- just enough any HTML data into the list, like a huge comment.
(Reporter)

Comment 5

15 years ago
Created attachment 94439 [details]
SMALL tags moved inside the DL tags

(I was looking for a workaround for my site, but it seemed to be rather hard.)
If the small tags are moved into the DL tags (compare the source to the first
attachment), DD items appear on new lines, but are not indented.

In fact these effects seem to happen also with other font formatting tags than
"SMALL", for example "I". The only workaround I have found is that the fotn
formatting must be done for each DT and DD item separately, like
<DT><SMALL>Term</SMALL><DD><SMALL>Description</SMALL>

Ok, I guess that this is enough for this bug this time.

Comment 6

15 years ago
Since <small> is just a special case of font, this looks like a dup of 117738.
Note that the markup used in all the attachments here is not valid HTML
(only the "workaround" described by Panu is using valid HTML).

Marking as duplicate of bug 117738, please reopen if you disagree.

*** This bug has been marked as a duplicate of 117738 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.