Closed Bug 1463640 Opened 2 years ago Closed 10 months ago

Janky scroll in dota2.gamepedia.com

Categories

(Core :: Graphics: WebRender, defect, P2)

62 Branch
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- fix-optional

People

(Reporter: crendking, Assigned: gw)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180522220730

Steps to reproduce:

Go to https://dota2.gamepedia.com/Heroes and scroll up and down.

Firefox version: 62.0a1 (2018-05-22) (64-bit), Windows, Radeon 290X


Actual results:

Scroll is janky on this particular page.


Expected results:

Scroll should be smooth.

Anecdotally, in Performance tab of developer tools, I see large number of requestAnimationFrame.
The page scrolls smoothly without WebRender
I found the cause of the problem. The name of each hero is done with a span. The span has the following style:

font-size:17px; color:white; text-shadow:-1px 0 0.2em black, 0 1px 0.2em black, 1px 0 0.2em black, 0 -1px 0.2em black;

The text-shadow is the problem. It looks like WebRender can't handle large number of elements with text-shadow.
Batch updating status flags based on WR schedule - please adjust if needed.
What fps do you get when scrolling? You can get the fps by turning on gfx.webrender.debug.profiler=true and gfx.webrender.debug.compact-profiler=true and making sure gfx.webrender.debug.gpu-time-queries and gfx.webrender.debug.gpu-sample-queries are false.
Flags: needinfo?(crendking)
Attached file a reduced html
If WebRender is enabled, the CSS text-shadow is very slow.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> What fps do you get when scrolling? You can get the fps by turning on
> gfx.webrender.debug.profiler=true and
> gfx.webrender.debug.compact-profiler=true and making sure
> gfx.webrender.debug.gpu-time-queries and
> gfx.webrender.debug.gpu-sample-queries are false.

My display refresh rate is 100hz. When scrolling https://dota2.gamepedia.com/Heroes, the FPS reduces to 2-4. Alice0775 White's attachment should exhibit the symptom even more clearly.
Flags: needinfo?(crendking)
Assignee: nobody → gwatson
Assignee: gwatson → dglastonbury
Dan's on PTO until Oct 15th
Assignee: dglastonbury → nobody
Glenn, do you expect this to be fixed by picture caching, or should we assign somebody in the mean time?
Flags: needinfo?(gwatson)
FYI: Glenn, Jeff and I met - our operating assumption is that it will be fixed by picture caching.
Flags: needinfo?(gwatson)
Assignee: nobody → gwatson

Both the attached test case and the provided URL run smoothly on my Intel HD4600 with picture caching enabled now.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.