Closed Bug 1463711 Opened 3 years ago Closed 3 years ago

unable to open /builds/worker/workspace/build/src/browser/config/mozconfigs/linux64/debug-searchfox-clang: No such file or directory

Categories

(Webtools :: Searchfox, defect, P5)

defect

Tracking

(firefox62 fixed)

RESOLVED FIXED
Tracking Status
firefox62 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kats)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Summary: Intermittent unable to open /builds/worker/workspace/build/src/browser/config/mozconfigs/linux64/debug-searchfox-clang: No such file or directory → unable to open /builds/worker/workspace/build/src/browser/config/mozconfigs/linux64/debug-searchfox-clang: No such file or directory
This looks like a regression from bug 1237182. Since that landed, the clobber step in this job is blowing away the entire src tree, and so then the build can't find the mozconfig. :catlee, can you take a look?
Blocks: 1237182
Flags: needinfo?(catlee)
I think we should remove the clobber step from the searchfox kind definition:
https://searchfox.org/mozilla-central/source/taskcluster/ci/searchfox/kind.yml#37,61

This matches what we do on linux:
https://searchfox.org/mozilla-central/source/taskcluster/ci/build/linux.yml#14
Flags: needinfo?(catlee)
Comment on attachment 8981197 [details]
Bug 1463711 - Remove clobber step from searchfox builds.

https://reviewboard.mozilla.org/r/247280/#review253368
Attachment #8981197 - Flags: review?(catlee) → review+
Assignee: nobody → bugmail
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/85c2c2f860d9
Remove clobber step from searchfox builds. r=catlee
https://hg.mozilla.org/mozilla-central/rev/85c2c2f860d9
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.