Closed Bug 1463720 Opened 2 years ago Closed 2 years ago

[Ubuntu] The fullscreen button from the zoom control bar is NOT visible in fullscreen mode when in dark theme

Categories

(Firefox :: Theme, defect, P2)

All
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1449547
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed
firefox62 --- fixed

People

(Reporter: JuliaC, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]:
- 62.0a1 (2018-05-22) 
- 61.0b7 build1 (20180521110957)

[Affected platforms]:
- Ubuntu 16.04 x64 

[Steps to reproduce]:
1. Launch Firefox
2. Enter the "Customize..." mode, set the dark theme and click the "Done" button
3. Go to Menu and click the fullscreen button from the zoom control bar
4. When in fullscreen mode, inspect the same button (see step 3)

[Expected result]:
- [step 3, step 4] The fullscreen button is visible and fully functional

[Actual result]:
- [step 4] The fullscreen button is not visible until is hovered

[Regression range]:
- Last good revision: 88657b4a0dd803dff57d82ee164fb549286d31b5
- First bad revision: 93ad00eae5749e9324484d979a078a045cb875ef
- Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=88657b4a0dd803dff57d82ee164fb549286d31b5&tochange=93ad00eae5749e9324484d979a078a045cb875ef
- it seems that bug 1451947 regressed this behaviour
:ntim, looks like this is a regression from a bug you fixed?
Blocks: 1451947
Component: Toolbars and Customization → Theme
Flags: needinfo?(ntim.bugs)
Priority: -- → P2
Hi Iulia, do you have a screenshot ?
Flags: needinfo?(iulia.cristescu)
Attached image Screenshot
Flags: needinfo?(ntim.bugs)
Flags: needinfo?(iulia.cristescu)
The issue is possibly the same fix as bug 1449547.

Also, I'd argue this is more a regression from bug 1408121 rather than 1451947.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1449547
Blocks: 1408121
No longer blocks: 1451947
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
See Also: 1449547
Duplicate of bug: 1449547
(In reply to Tim Nguyen :ntim from comment #2)
> Hi Iulia, do you have a screenshot ?

Hello Tim! Here's a screencast showing the issue https://drive.google.com/file/d/1ErDNrmZTYeBTtorbCsTjZ80Jbph3Y2Rk/view?usp=sharing.
You need to log in before you can comment on or make changes to this bug.