Closed Bug 1463767 Opened 2 years ago Closed 2 years ago

Bustage in dom/file/nsHostObjectProtocolHandler.cpp when Gecko 62 merges to Beta on 2018-06-14

Categories

(Core :: DOM: Core & HTML, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 + verified

People

(Reporter: aiakab, Assigned: baku)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

[Tracking Requested - why for this release]:

Central as Beta simulation https://treeherder.mozilla.org/#/jobs?repo=try&revision=9211b82c555e9243e7e76c30b63a1af5813e89d5&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable&selectedJob=179828563


This is from Bug 1453971 
/builds/worker/workspace/build/src/dom/file/nsHostObjectProtocolHandler.cpp:484:19: error: type 'nsINamed' is not a base type for type 'mozilla::ReleasingTimerHolder'
Flags: needinfo?(amarchesini)
Attached file m-b (obsolete) —
Patch for beta.
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Priority: -- → P1
Is that patch work in progress or supposed to get reviewed?
Flags: needinfo?(amarchesini)
This patch is ready to be merged. I just fixed the compilation issue. The patch has been reviewed in bug 1453971.
I don't think an extra review is needed.
Flags: needinfo?(amarchesini)
Comment on attachment 8979986 [details]
m-b

So given this broken setup in https://searchfox.org/mozilla-central/source/xpcom/threads/nsThreadUtils.h#439-441 I guess this won't really help. I mean, when the code next time lands to beta, it will fail again.
Attachment #8979986 - Flags: review-
Attached patch stable.patchSplinter Review
Attachment #8979986 - Attachment is obsolete: true
Attachment #8980547 - Flags: review?(bugs)
Attachment #8980547 - Flags: review?(bugs) → review+
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/109d4f846f31
ReleasingTimerHolder should expose nsINamed::GetName only if MOZ_COLLECTING_RUNNABLE_TELEMETRY is defined, r=smaug
https://hg.mozilla.org/mozilla-central/rev/109d4f846f31
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Looks like this got fixed, but I can track in case it reopens.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.