Closed Bug 1463792 Opened 3 years ago Closed 3 years ago

svg items disappear when scrolled out of view

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- disabled
firefox60 --- disabled
firefox61 --- disabled
firefox62 --- fixed

People

(Reporter: jrmuizel, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(1 file)

Scroll the circles of the attached test case out of view and they don't come back when scrolled back.
Attached file svg-rect-resize.html
¹) if the zoom level is >= 140% (Debian Testing, KDE, Radeon RX480, Xorg, 2560x1440).
This is caused by bug 1458968
Depends on: 1458968
It looks like this exposed an existing bug in WebRender. If the contents of a blob image go out of view WebRender won't remember them and it only asks for the newly invalid region. i.e. If we don't clip our rendering to the dirty rect the items don't go away.
Batch updating status flags based on WR schedule - please adjust if needed.
Priority: -- → P1
This is fixed now.
Blocks: 1458968
Depends on: 1463416
No longer depends on: 1458968
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Assignee: nobody → bugmail
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.