[DOGFOOD] [PERF] Loading directory listings takes ~30 times longer

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: cpratt, Assigned: Chris Waterson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Perf][BETA], URL)

(Reporter)

Description

19 years ago
Build ID: 1999092208
Platform: Windows 98, Linux

To reproduce:
- Launch apprunner
- Start a stopwatch
- Load the above URL

Result: It loads... eventually. Initially, you quickly see some files in this
directory - albeit without the accompanying icons. Within about 10 seconds,
Windows will list apprunner as 'not responding'. On a 166 MHz Pentium running
Windows 98, it takes approximately 50-55 seconds for apprunner to eventually
display the appropriate icons and then return control to the user. On Linux, it
took a similar amount of time on a 350 MHz Pentium II machine.

Expected result: 4.7 performance. Using 4.7, the same Pentium running Windows 98
loads the page in under 2 seconds. 50-55 seconds is not acceptable.
(Reporter)

Updated

19 years ago
QA Contact: leger → cpratt
Summary: [PERF] Takes too long to load directory listings → [PERF] Loading directory listings takes ~30 times longer
Whiteboard: [BETA]

Updated

19 years ago
Assignee: don → waterson

Comment 1

19 years ago
probably one for waterson
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Reporter)

Updated

19 years ago
Severity: major → normal

Updated

19 years ago
Whiteboard: [BETA] → [Perf][BETA]
(Assignee)

Updated

19 years ago
Summary: [PERF] Loading directory listings takes ~30 times longer → [DOGFOOD] [PERF] Loading directory listings takes ~30 times longer

Comment 2

19 years ago
cpratt, can you check this out with todays build please?
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

19 years ago
Seems to be working fine in the 1999110108 build, Windows 98.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.