Multiple reftest failures about colors/animations and about scrolling when Gecko 62 merges to Beta on 2018-06-14

VERIFIED FIXED in Firefox 61

Status

()

defect
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: apavel, Assigned: mattwoodrow)

Tracking

(Blocks 2 bugs)

unspecified
mozilla62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61+ verified, firefox62+ verified)

Details

(Whiteboard: gfx-noted[stockwell disable-recommended])

(Reporter)

Updated

a year ago
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(bugmail)
Some mochitests are also affected. There are test failures related to animations and ones related to scrolling - issue with retained display lists, e.g. bug 1462497?
Weird. I can't think of anything that would explain this set of failures. Even stranger is that the failures seem to only happen on opt builds, debug is pretty green. Certainly a lot of the errors look painting or graphics related, and they don't seem to affect Android at all. At this point my best guess is that including WebRender is causing some sort of miscompilation - it might be worth doing a try push with https://hg.mozilla.org/mozilla-central/rev/c593385aff7a backed out and see if that helps any.
Flags: needinfo?(bugmail)
Ok, then I don't know what's going on. Have you tried bisecting from the last merge to beta to narrow down the range in which this problem was introduced?
Flags: needinfo?(bugmail)
FWIW, this only affects builds that don't have MOZ_DIAGNOSTIC_ASSERT set. Both debug and DevEdition were fine.
Whiteboard: gfx-noted
This should be fixed by Matt's follow-up push to the regressing bug.
https://hg.mozilla.org/mozilla-central/rev/69dca4b4848f
Assignee: nobody → matt.woodrow
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
I'll go ahead and call this verified based on a much greener Beta uplift today.
Status: RESOLVED → VERIFIED
Flags: needinfo?(matt.woodrow)
Duplicate of this bug: 1464333
Comment hidden (Intermittent Failures Robot)
(Assignee)

Updated

a year ago
Blocks: 1466010
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.