Closed Bug 1463920 Opened 4 years ago Closed 4 years ago

Browser hang/crash due to huge memory usage

Categories

(Core :: CSS Parsing and Computation, defect)

61 Branch
x86_64
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1461285

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: hang, regression)

[Tracking Requested - why for this release]: Crash and hang

Reported in http://forums.mozillazine.org/viewtopic.php?p=14801143#p14801143

Reproducible: always:

Steps To Reproduce:
1. Open URL (NSFW content)

Actual Results:
Firefox61 Beta Firefox Hangs. Notice it uses huge Memory.
Sometimes, crash reporter pops up after closing by [x] button.

Expected Results:
Browser should not hang.
CPU and Memory usage should not be hogging.


Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7ba4b70ba892ed1ba575c683408eb378a52aba0b&tochange=62908a56c59f34e4dd5175717228cd514ac65c60

Regressed by:
62908a56c59f	Xidorn Quan — servo: Merge #20582 - Have CSSOM append rather than replace slot in declaration block (from upsuper:cssom-append); r=emilio


Unable to set Block bug because landing without bug number :(
Flags: needinfo?(xidorn+moz)
The patch of Bug 1460295 seems to fix this problem.
Depends on: 1460295
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(xidorn+moz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1463791
Duplicate of bug: 1461285
You need to log in before you can comment on or make changes to this bug.