Closed Bug 1463939 Opened 2 years ago Closed 2 years ago

NativeIterator field style patrol

Categories

(Core :: JavaScript Engine, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: Waldo, Assigned: Waldo)

Details

Attachments

(4 files)

No description provided.
Some of the member functions added here are a little awkward-fitting, sort of, but I tried not to do too much refactoring of stuff outside of NI, to inside of it.
Attachment #8980141 - Flags: review?(jdemooij)
Bwhahahaha, this bug is *exactly* one thousand bugs past bug 1462939 where this was requested!  \o/
Attachment #8980140 - Flags: review?(jdemooij) → review+
Attachment #8980141 - Flags: review?(jdemooij) → review+
Attachment #8980142 - Flags: review?(jdemooij) → review+
Comment on attachment 8980143 [details] [diff] [review]
Make NativeIterator::guard_key private and named consistent with normal SpiderMonkey style

Review of attachment 8980143 [details] [diff] [review]:
-----------------------------------------------------------------

Cool, thanks.

When you land this you'll probably want to check it still compiles; I landed some conflicting changes I think.
Attachment #8980143 - Flags: review?(jdemooij) → review+
Pushed by jwalden@mit.edu:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8f1d10d34e9c
Make NativeIterator::obj_ private, give it a clearer name, and add public accessors to observe or modify it.  r=jandem
https://hg.mozilla.org/integration/mozilla-inbound/rev/ceccac3e93a1
Make NativeIterator::propertyCursor_ private, add a nextProperty() accessor for when its value is needed, and add various member functions for things better expressed as verbs than by calling nextProperty() manually.  r=jandem
https://hg.mozilla.org/integration/mozilla-inbound/rev/702e8d474a20
Make NativeIterator::flags private and tack an underscore onto it.  r=jandem
https://hg.mozilla.org/integration/mozilla-inbound/rev/e04fb8536063
Make NativeIterator::guard_key private and named consistent with normal SpiderMonkey style.  r=jandem
Pushed by jwalden@mit.edu:
https://hg.mozilla.org/integration/mozilla-inbound/rev/06507a170eac
Followup bustage fix.  r=bustage in a CLOSED TREE
You need to log in before you can comment on or make changes to this bug.