Mozilla 1.0 rc2 starts with splash screen but closes without anything

RESOLVED WORKSFORME

Status

Core Graveyard
Profile: BackEnd
--
critical
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Marc Bauer, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

Mozilla 1.0 rc2 will not start. seams to be a Netscape 4 incompatibiliy.

this BUG is in all mozilla versions up to 1.0 rc2!

Reproducible: Always
Steps to Reproduce:
i've logged into a computer where netscape 4.76 was installed. after this i
tryed to install Mozilla on another computer. installation was no problem.

but if i try to start mozilla the mozilla logo comes up and then close. mozilla
will not start! i tryed some things...

started the profilemanager - my profile information is everytime lost! if i
create a new one and give the old path of my settings this settings will be used
- now my default profile is listed in profilemanager. now i can start mozilla
from profilemanager. but if i close mozilla now and try to restart it - it will
not start - and in profilemanager there is no profile listed!


Actual Results:  Mozilla will start once. after a close the same procedure is
need to startup mozilla (profile ist lost and so on).
Reporter:

Do you gave Mozilla the Path to your old NS4.7x Profile (that Mozilla should use
your old Porfile) or Do you migrated the 4.7x Profile ?
A brand new profile (not migrated etc.) works ?
Severity: blocker → critical
(Reporter)

Comment 2

16 years ago
i have never installed NS4.7 on my pc - i installed it on different other pc's
in our network. only with my Windows UserProfile. i have tested everything.
uninstall mozilla on my pc. remove all mozilla profiles by hand. (netscape isn't
installed!!!) and tryed to remove all registry keys if available in
HKLM\Software\Netscape, HKCU\Software\Netscape, HKLM\Software\Netscape,
HKLM\Software\Mozilla, HKCU\Software\Mozilla, HKLM\Software\Mozilla.org,
HKCU\Software\Mozilla.org and do a fresh reinstall - but nothing helps!

i see the same problem on our developpers PC - having NS47 installed and NS6.2.
this will not work too. maybe there are some keys in the registry i cannot find
- creating this problems - but i cannot find them.

i think this is a blocker and not "only" critical - this bug makes me not use
NS6 + 7 or Mozilla. i cannot start it. i found another user having the same
problem on a newsgroup. he is working in support center and haven't found a
solution yet - too.
blocker= blocks development

You create a new profile and if you start mozilla with this new profile mozilla
closes itself and the new created Profile is gone ?



Component: Browser-General → Profile Manager BackEnd
(Reporter)

Comment 4

16 years ago
today i can only start mozilla about Profile Manager. but *everytime* i start 
profilemanager after closing mozilla - the profiles i created, are not listed 
in the right listbox. i created several profiles! if i tell the profilemanager 
the path of one of this profile and say finish - the manager ask me - 
use/overwrite profile (or something like this) i say - yes. and now this 
profile is listed in the listbox and i can start mozilla with this profile.

after closing now mozilla and reopen the profilemanager the profile listed 
some seconds bevor is away! ist looks like the profiles config will not saved 
and reread on startup

ok - if blocker ist only for development - i agree with you.
Priority: -- → P1
Target Milestone: --- → mozilla1.0
please don't touch the priority and target milestone fields.

-> Profile Manager default owner
Assignee: Matti → ccarlen
Priority: P1 → --
QA Contact: imajes-qa → ktrina
Target Milestone: mozilla1.0 → ---
(Assignee)

Comment 6

16 years ago
Can you find the file registry.dat? For a non-roaming setup, it should be at
C:\WINNT\Profiles\<user>\Application Data\Mozilla. I wonder if it's getting
created. Also, within the "Profiles" dir within that same dir, are there any
profile dirs corresponding to the profiles you made?
(Reporter)

Comment 7

16 years ago
no i cannot find a registry.dat in this and any other dir.

i will tell you something about the environment. we use roaming userprofiles.
they are deletet localy if a user logoff and will be saved back to a server
share. if he logs in the profiles will be copied fromo there and the
"Anwendungdaten" (application data) folder will be redirected about Folder
Redirection to "\\SERVER\%username%$\Anwendungdaten". in this folder i have
found a Mozilla.org Dir (i think i have created this in the past by hand). i
have a C:\Dokumente und Einstellungen\username\Application Data dir - but this
dir doesn't contain any Mozilla dir.

there is no other local userdir containing Mozilla dirs... all profiles will be
localy deleted on logoff.

i think this need to be fixed with 1.0 - this is a showstopper for all users
doing a upgrade. i remember - on the first startup it tells me to migrate ns4
profile i haven't. i have canceled this, but today i cannot tell you how. i
think a very often no no no... i have kick it away. since 0.93 i have this bug
and i cannot fix this - testing mozilla makes no fun with this.
(Reporter)

Comment 8

16 years ago
something ne to this case?
(Reporter)

Comment 9

16 years ago
i have deleted the profiles dir and have created a new one. now mozilla will
start. but i ask why mozilla isn't detection a corruption or a problem in their
config files and repaire this themself!? additional i have never changed
anything in this files by hand. this is corrupted by mozilla.
-->Resolving Worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
Status: RESOLVED → VERIFIED

Comment 11

16 years ago
Verified WFM. Marc, you may want to submit a separate bug regarding mozilla not
detecting a config file corruption or repairing itself. 
(Reporter)

Comment 12

16 years ago
i have reconfirmed the real cause of this bug. Mozilla up to 1.2.1 tested and 
Netscape 7.01 tested. and here i describe how to reproduce for admin newbies. 
it is a Windows Problem (in Network Environment) with redirected Application 
Data Directory!

0. install on clean box
1. go to microsft active directory and create a policy redirecting 
the "Application Data" to a Network share for the network user you will use 
later "\\server\username$\Application Data"
2. set up the useraccount with HOMEDIR "U:\" connecting 
to "\\server\username$" for this user (share i directory first with username$)
3. log on with the network account (or local account). now you have U:\ mapped 
and see the Application Data Dirretory
4. install 4.7 on the box if not installed
5. install Mozilla
6. Mozilla will display the spash screen and will close
7. log on as local admin *without* network HOME
8. start mozilla, create the profile and everything is good!!! restarts will 
work, too - no problems!
9. now copy this profile to any location you like (you need access with the 
network account you will logon next.
10. logoff and logon as the Domain Network Account
11. try to start mozilla on this account
12. it will display the spash and will close
13. now - copy the copied profile (created with local admin) 
to "\\server\username$\Application Data". will 
be "\\server\username$\Application Data\(Mozilla\Profiles\*) like the normal 
directory structure mozilla will create
14. start Mozilla - OHHHHH ist comes UP!!!


now - i hope you are able to follow all this... and create a fix. this product 
is absolutly unusable with redirected Application Data Directories!!! looks 
like Mozilla will not correcly read the registry key in 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell 
Folders or will crash with the UNC path... i don't now the realy cause. have 
look to the code please. maybe a UNC path problem...
Status: VERIFIED → UNCONFIRMED
Depends on: 186992
OS: All → Windows 2000
Resolution: WORKSFORME → ---
(Reporter)

Comment 13

15 years ago
someone out there able to fix this bugs?

Comment 14

15 years ago
Reporter: Please re-attempt with newest build, as mucho time has passed and this
may have been fixed.

If fixed, please resolve as WORKSFORME.

Thanks!

 (BugDay: 13Jan2004)

Comment 15

15 years ago
Marc,

This could have been fixed by the fix for bug 162025.
(Reporter)

Comment 16

15 years ago
next time i install a developer PC i will review this with 1.6 - but from memory
in 1.4 final it is not fixed.
(In reply to comment #16)
> next time i install a developer PC i will review this with 1.6 - but from memory
> in 1.4 final it is not fixed.

Any progress on this?
(Reporter)

Comment 18

14 years ago
sorry - no. haven't tryed it yet. forgotton to test...

Comment 19

14 years ago
-> worksforme for now
reporter (Marc), reopen if you can (find the time to test and) reproduce this in
a recent build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → WORKSFORME
Summary: Mozilla 1.0 rc2 will start moz-logo and close without anything → Mozilla 1.0 rc2 starts with splash screen but closes without anything
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.