Closed Bug 14641 Opened 21 years ago Closed 19 years ago

When window restored, contents not refreshed if changed

Categories

(SeaMonkey :: General, defect, P3, major)

x86
Windows NT

Tracking

(Not tracked)

RESOLVED WORKSFORME
mozilla0.9

People

(Reporter: cpratt, Assigned: kmcclusk)

References

()

Details

Build ID: 1999092208
Platform: Windows NT

To reproduce:
- Launch apprunner
- Load the above URL (it changes pages every 60 seconds)
- After the first page has loaded, minimize the application
- Wait about 65 seconds; watch the Taskbar to see when the page changes
- Restore the window

Result: The content of the window is now entirely black save for the Sidebar.

Expected result: It should look 'normal' upon restore.
QA Contact: leger → cpratt
Assignee: don → rickg
This is still occuring with nov.1 build at the site,
http://grok/tests/page_loader/test_url_30.html

If the content changes while the window is minimized, it will not show up when
you restore the window. In current builds, the window actually shows up as all
white when you restore it.

Rick, would this be your area?
Assignee: rickg → beard
Patrick -- this sounds like a job for porkjockey::paint.
Status: NEW → ASSIGNED
Kevin, isn't this a duplicate bug?
Assignee: beard → kmcclusk
Status: ASSIGNED → NEW
Kevin, please check if our work affects this bug.
Status: NEW → ASSIGNED
Target Milestone: M14
Tried with 1/20/2000 build on WIN95, WINNT mozilla and it works for me. I 
minimized the window after loading both 
http://grok/tests/page_loader/test_url_60.html and 
http://grok/tests/page_loader/test_url_30.html  and each time it refreshed the 
all of the windows in the frameset.

Marking as worksforme.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
QA Contact: cpratt → sairuh
this isn't in my realm --eli, would this go to you or someone else? thx!
QA Contact: sairuh → elig
Using 2.7.00 AM build on NT 4.0 SP5, I'm still seeing the problem described by 
Chris with the http://grok/tests/page_loader/test_url_60.html example.

Specifically, after a one-minute wait, the window turns white.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Moving to M15.
Target Milestone: M14 → M15
The problem is the webshell and all associated windows for the content area is 
destroyed and re-created when the document changes while mozilla is minimized. 
When the windows are recreated they have 0 width and height. We reflow the 
document in zero sized views which will not paint when the window is restored. 
We also trigger an ASSERTION in nsView because the clip is set to a negative 
value because the borderwidth is subtracted from 0 sized height yielding a 
negative value. 

Moving to M17
Target Milestone: M15 → M17
This bug has been marked "future" because the original netscape engineer working
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way
-- please attach your concern to the bug for reconsideration.
Target Milestone: M17 → Future
*** Bug 39062 has been marked as a duplicate of this bug. ***
QA Contact: elig → doronr
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → WORKSFORME
Target Milestone: Future → mozilla0.9
With todays build I can not get it to fail.
Marking WORKSFORME.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.