debugger is blank when opened

VERIFIED FIXED in Firefox 68

Status

defect
P1
normal
VERIFIED FIXED
Last year
22 days ago

People

(Reporter: davidpuc04, Assigned: jdescottes)

Tracking

(Blocks 1 bug)

60 Branch
Firefox 68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 verified)

Details

Attachments

(2 attachments)

Reporter

Description

Last year
Posted image Screenshot_1.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180516032328

Steps to reproduce:

When I open the debugger this is in blank, i can´t do anything.

Thisha happen with any page that I try to debug

I have fireforx quantum 60.0.1 (64-bits), my so is windows 10 


Actual results:

Debugger in blank


Expected results:

I need to debug
Group: firefox-core-security
Component: Untriaged → Developer Tools: Debugger
Summary: debugger → debugger is blank when opened
I'm sorry you are seeing this, could you share a bit more about what you're seeing?
The browser console should have the error
https://developer.mozilla.org/en-US/docs/Tools/Browser_Console

Also, does this happen with a new profile?
Reporter

Comment 2

Last year
This problem is not in the console when I open the debugger either when press CTRL + SHIFT + I or when open developer tools web

https://s22.postimg.cc/w2xp0n6u9/Screenshot_2.png

Updated

Last year
Product: Firefox → DevTools

Comment 3

10 months ago
David Puc Poot is right. This bug has been occurring since a really time ago. The new debugger from version 52 and above doesn't show at all. This problem has been reported 3 times on the Firefox Support Forum (in Spanish) but it doesn't seem to have a real solution by now.

My current OS is Windows 7 64 Bits using Firefox Developer Edition 63.0b2, but it also occurs on my home-personal computer with an OS Windows 10 32 Bits with Firefox (the standard edition) 61.0.2.

I have already tried even reinstalling Firefox multiple times without any success.

The only temporary solution we have is to change the option 'devtools.debugger.new-debugger-fronted' to false in about:config and use the old debugger, as specified by the page 'Open the debugger - Firefox Developer Tools | MDN (https://developer.mozilla.org/en-US/docs/Tools/Debugger/How_to/Open_the_debugger )'.

Here I will attach a shared album in Google Photos with various images regarding more details about this problem (including a picture of the Browser Console):

https://photos.app.goo.gl/kQ5WpZuyeJbXHXov9

If any additional information is needed I will be happy to help. I was being patient with this problem, but it has happened a lot of time, and still the same. I hope this help resolve the problem.
Hi, I'm sorry this is happening and we will definitely address it. This looks an issue with localization, which we should easily be able to address.
Apologies for the difficulties Mikiztli and David.  I downloaded Firefox 62 (64-bit) in ES (Spain) and the new debugger works without problem.  The error stack appears to show a localization issue.  A few questions for you:

1.  Can you confirm the language code you're using?
2.  Could you download Firefox Nightly and give that a shot?  Using Nightly will help me associate the error line numbers with the most recent code so I can figure out what localization string may be missing.
3.  Could you try with a fresh profile?

I'll keep digging on my side.  Thank you!
Flags: needinfo?(mikionlopezmartinez55)
Flags: needinfo?(davidpuc04)
Additional bit of information; the devtools-launchpad, which we develop the debugger in, throws an error if we try to use a L10N key that doesn't exist, and we'd have caught a bad key right away, so there's definitely something weird going on.

Comment 7

10 months ago
Hello. Thanks for responding and attending this situation. Here I will write in a list of the information you requested:

1. In my case, Firefox its using es-MX as language code.

2. I downloaded Firefox Nightly (64.0a1 - es-MX) and tried to run the debugger, it happens the same problem. I updated the shared album on Google Photos with the errors on the Browser Console. But this time I clicked on the grey arrow to show more details about them (hope it's useful). I will put the link in here again: https://photos.app.goo.gl/kQ5WpZuyeJbXHXov9

3. I created another profile with the Profile Manager, named it NightlyDBG (Nightly Debug) and run it on Firefox Nightly. Yet the problem still occurs, the errors on the Browser Console shows the exact same lines and names as before, so I didn't see the point on taking a screenshot of that.

Thanks again for attending the situation, I will remain attentive to any reply and/or requests for more information. Appreciate it!.
Flags: needinfo?(mikionlopezmartinez55)
I've fixed the broken string, it should be in tomorrow's Nightly.

Having said that, I'd really keep the bug open to figure out how to make the l10n logic less brittle.

Comment 9

10 months ago
I've downloaded today's Nightly (07/09/2018) and yes, finally the debugger opened as expected. I'm so happy that this problem has finally been resolved, and I really thank you guys for all the support through the process.

I just have one final question (if it's possible to answer): The error is resolved but, by now, is only fixed in Firefox Nightly. How much time could be needed in order to be available on the rest of the editions of Firefox, including the standard?
:flod, how could we get the fix uplifted to beta?
Flags: needinfo?(davidpuc04) → needinfo?(francesco.lodolo)
It's already in beta. It it wasn't in the last build, it will definitely be in the next one, since I've already updated the sign-off for es-MX.
Flags: needinfo?(francesco.lodolo)
(In reply to Mikiztli ML from comment #9)
> How much time could be needed in order to be available on the rest of the editions of Firefox,
> including the standard?

It will hit release with Firefox 63 (October 23).

Comment 13

10 months ago
Understood, thanks for all the wonderful support. I'll be on the watch.

Comment 14

7 months ago
Ran into this same issue. I isolated my particular issue to dom.indexedDB.enabled set to false. When I set this to true, the debugger appeared once again.

Comment 15

6 months ago

I'm experiencing this issue in Firefox 64.0.2 (release). This doesn't happen to me in Firefox Dev 65.0b10 .
Didn't the fix hit release with Firefox 63?

(In reply to EmuAGR from comment #15)

I'm experiencing this issue in Firefox 64.0.2 (release). This doesn't happen to me in Firefox Dev 65.0b10 .
Didn't the fix hit release with Firefox 63?

Are you using Firefox in Mexican Spanish (es-MX)?

Comment 17

5 months ago

Sorry for the late reply.
My locale is Spanish-Spain (es-ES). Now using Firefox 65.0, the problem persists.

(In reply to EmuAGR from comment #17)

Sorry for the late reply.
My locale is Spanish-Spain (es-ES). Now using Firefox 65.0, the problem persists.

Does it happen on a new profile?

Same issue here (again) with en-GB missing translation, causing Debugger tab to be empty. See bug 1520181.

Francesco: do we need to fix more strings here (in other locales)?

Any specific strings that cause the trouble? (some fixed in the comment #8)

Honza

Flags: needinfo?(francesco.lodolo)

As per comment 8, the solution here is to fix the code so that it doesn't break for a wrong localization.

Having said that, I'm not aware of any issues with strings at the moment. If there are, someone should test that locale and version and see if it can be reproduced.

Flags: needinfo?(francesco.lodolo)
Blocks: dbg-frontend
Priority: -- → P1
Assignee: nobody → jlaster
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Throwing errors can lead to blank panels when we uplift strings to beta and language packs have not been regenerated yet.
Try at: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1520df8aa12a84b5c50b205ffda49a1e86e545c9

Whiteboard: [debugger-mvp]

Comment 23

Last month
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/09549fc20d23
devtools l10n use console.error if localized string is unavailable r=jlast
Assignee: jlaster → nobody
Status: ASSIGNED → UNCONFIRMED
Ever confirmed: false
Whiteboard: [debugger-mvp]
Status: UNCONFIRMED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → jdescottes
Duplicate of this bug: 1451773
Flags: qe-verify+

While I was unable to confirm the issue, I did double check that there is no issue on the mentioned locales for 68.0b7:

  • en-US (Windows 10, macOS 10.13, Ubuntu 16.04);
  • en-GB + es-ES on Windows10.

There where no issues obvious issues with the debugger so marking this as verified.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.