Print preview causes Mozilla to crash at www.exact.nl (N7PR1, M1RC3)

VERIFIED WORKSFORME

Status

()

Core
Print Preview
--
critical
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Eric de Redelijkheid, Assigned: rods (gone))

Tracking

({crash})

Trunk
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Visit http://www.exact.nl (b.t.w. Languages for Web Pages is Dutch).

On the main page klick "PRODUCTEN"
On the page that appears next klick "Exact Globe 2000"
On the page that appaers next klick "Systeemvereisten" (in the menu)

If you want a print preview of that page, Mozilla crashes.

Build 2002051006.
Problem also appears in Netscape 7.0PR1
(Reporter)

Comment 1

16 years ago
Created attachment 84755 [details]
Dr. Watson output

This is an extract from the file drwtsn32.log
(Reporter)

Comment 2

16 years ago
Created attachment 84756 [details]
Dr. Watson output

Again an extract from drwtsn32.log, but this time from a Mozilla crash instead
of Netscape 7.0PR1
Created attachment 84760 [details]
DrWatson log file
I tried upper mentioned page and also mozilla crashed while trying to print preview.

(Using Build ID 2002052305  on Windows 2000) - Dr. Watson output attached.

Comment 5

16 years ago
can you post Talkback ID for this crash ?
Keywords: crash, stackwanted

Comment 6

16 years ago
Mozialla also crashes with OS Windows 2000 (sp2) Build 20020510006
(Reporter)

Comment 7

16 years ago
Talkback incident ID TB6591056M (Netscape) TB6591375Y (Mozilla)

Comment 8

16 years ago
Marking NEW as this happens with NS7PR1, reproduced by other people and to get
attention in order to retreive Talkback data.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

16 years ago
Also crash on Linux 2002051809 1.0RC3 branch, TB6605688Y.

Comment 10

16 years ago
Petersen, isn't this bug Layout problem?

gklayout!NS_NewPresShell 
gklayout!NS_NewFrameManager  (FPO: [EBP 0x02DC8D68] [2,0,4])
gklayout!NS_NewPrintPreviewContext  (FPO: [1,0,2])
gklayout!NS_NewFrameManager  (FPO: [2,0,2])
gklayout!NS_NewFrameManager 

BTW bug 146597 maybe should be dupe of this.
Keywords: stackwanted
OS: Windows NT → All
Summary: Print preview causes Mozilla to crash at page within the site www.exact.nl → Print preview causes Mozilla to crash at www.exact.nl (N7PR1, M1RC3)
(Assignee)

Comment 11

16 years ago
When I go to this site it just wants me to download some exe file.

Comment 12

16 years ago
Original URL doesn't work, can't reproduce crash.
Should this be marked invalid ?
(Reporter)

Comment 13

16 years ago
I can provide you with an URL for the frame which I copied using IE6 going to
that same area on the site:

http://www.exact.nl/docs/BDDocument.asp?Action=View&ID={F84B4C68-1A6B-442C-822C-E45A7024C184}&noheader=1&nosubject=1

But print preview of only that frame does not reproduce the crash. Trying to
open http://www.exact.nl with Mozilla, results in Mozilla asking for a directory
to save   the file BDBinDoc.asp.exe from http://www.exact.nl/docs/BPWebSite.asp.
In IE, the site mentions: Best viewed with Internet Explorer 5.5+.

I don't think it will be possible to reproduce the crash, unless Exact creates a
website usable for other browsers than IE.

Comment 14

16 years ago
Filled TechEvang bug 158879, adding dependency.
Depends on: 158879

Comment 15

16 years ago
if you disable Javascript, you can pull up the URL you get before it delivers a
binary executable to you:

http://www.exact.nl/docs/BPWebSite.asp

loading that URL (with Javascript disabled) and Print Preview both worked fine.
linux build 20020728
(Assignee)

Comment 16

16 years ago
WFM
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 17

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.