Closed Bug 1464351 Opened 3 years ago Closed 3 years ago

Intermittent org.mozilla.geckoview.test.GeckoSessionTestRuleTest#forCallbacksDuringWait_limitedToLastSessionWait | status -2

Categories

(GeckoView :: General, defect, P2)

defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62 fixed)

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jchen)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=180186230&repo=autoland

https://queue.taskcluster.net/v1/task/J3owZT5lTuCLq3vHhQqgfQ/runs/0/artifacts/public/logs/live_backing.log

[task 2018-05-25T07:08:14.212Z] 07:08:14     INFO -  TEST-START | org.mozilla.geckoview.test.GeckoSessionTestRuleTest.forCallbacksDuringWait_limitedToLastSessionWait
[task 2018-05-25T07:08:30.849Z] 07:08:30     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2018-05-25T07:08:30.850Z] 07:08:30     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=8
[task 2018-05-25T07:08:30.850Z] 07:08:30     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.GeckoSessionTestRuleTest
[task 2018-05-25T07:08:30.850Z] 07:08:30     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2018-05-25T07:08:30.850Z] 07:08:30     INFO -  org.mozilla.geckoview.test | Error in forCallbacksDuringWait_limitedToLastSessionWait(org.mozilla.geckoview.test.GeckoSessionTestRuleTest):
[task 2018-05-25T07:08:30.850Z] 07:08:30     INFO -  org.mozilla.geckoview.test | java.lang.AssertionError: onPageStop call count should be within limit
[task 2018-05-25T07:08:30.850Z] 07:08:30     INFO -  org.mozilla.geckoview.test | Expected: a value less than or equal to <0>
[task 2018-05-25T07:08:30.851Z] 07:08:30     INFO -  org.mozilla.geckoview.test |      but: <1> was greater than <0>
[task 2018-05-25T07:08:30.851Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.hamcrest.MatcherAssert.assertThat(MatcherAssert.java:20)
[task 2018-05-25T07:08:30.851Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.Assert.assertThat(Assert.java:956)
[task 2018-05-25T07:08:30.852Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.checkThat(GeckoSessionTestRule.java:844)
[task 2018-05-25T07:08:30.852Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.assertAllowMoreCalls(GeckoSessionTestRule.java:851)
[task 2018-05-25T07:08:30.852Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.forCallbacksDuringWait(GeckoSessionTestRule.java:1651)
[task 2018-05-25T07:08:30.852Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.BaseSessionTest.forCallbacksDuringWait(BaseSessionTest.kt:100)
[task 2018-05-25T07:08:30.852Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.GeckoSessionTestRuleTest.forCallbacksDuringWait_limitedToLastSessionWait(GeckoSessionTestRuleTest.kt:1054)
[task 2018-05-25T07:08:30.852Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-05-25T07:08:30.853Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-05-25T07:08:30.853Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
[task 2018-05-25T07:08:30.853Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
[task 2018-05-25T07:08:30.853Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
[task 2018-05-25T07:08:30.853Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
[task 2018-05-25T07:08:30.853Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$4.evaluate(GeckoSessionTestRule.java:1246)
[task 2018-05-25T07:08:30.854Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.support.test.internal.statement.UiThreadStatement$1.run(UiThreadStatement.java:44)
[task 2018-05-25T07:08:30.854Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2018-05-25T07:08:30.854Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-05-25T07:08:30.854Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-05-25T07:08:30.854Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.os.Looper.loop(Looper.java:137)
[task 2018-05-25T07:08:30.854Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2018-05-25T07:08:30.854Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-05-25T07:08:30.855Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-05-25T07:08:30.855Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2018-05-25T07:08:30.855Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2018-05-25T07:08:30.855Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at dalvik.system.NativeStart.main(Native Method)
[task 2018-05-25T07:08:30.855Z] 07:08:30     INFO -  org.mozilla.geckoview.test |
[task 2018-05-25T07:08:30.855Z] 07:08:30     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=60
[task 2018-05-25T07:08:30.855Z] 07:08:30     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=java.lang.AssertionError: onPageStop call count should be within limit
[task 2018-05-25T07:08:30.856Z] 07:08:30     INFO -  org.mozilla.geckoview.test | Expected: a value less than or equal to <0>
[task 2018-05-25T07:08:30.856Z] 07:08:30     INFO -  org.mozilla.geckoview.test |      but: <1> was greater than <0>
[task 2018-05-25T07:08:30.857Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.hamcrest.MatcherAssert.assertThat(MatcherAssert.java:20)
[task 2018-05-25T07:08:30.857Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.Assert.assertThat(Assert.java:956)
[task 2018-05-25T07:08:30.858Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.checkThat(GeckoSessionTestRule.java:844)
[task 2018-05-25T07:08:30.858Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.assertAllowMoreCalls(GeckoSessionTestRule.java:851)
[task 2018-05-25T07:08:30.859Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.forCallbacksDuringWait(GeckoSessionTestRule.java:1651)
[task 2018-05-25T07:08:30.859Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.BaseSessionTest.forCallbacksDuringWait(BaseSessionTest.kt:100)
[task 2018-05-25T07:08:30.860Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.GeckoSessionTestRuleTest.forCallbacksDuringWait_limitedToLastSessionWait(GeckoSessionTestRuleTest.kt:1054)
[task 2018-05-25T07:08:30.861Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-05-25T07:08:30.861Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-05-25T07:08:30.862Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
[task 2018-05-25T07:08:30.863Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
[task 2018-05-25T07:08:30.863Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
[task 2018-05-25T07:08:30.864Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
[task 2018-05-25T07:08:30.864Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$4.evaluate(GeckoSessionTestRule.java:1246)
[task 2018-05-25T07:08:30.865Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.support.test.internal.statement.UiThreadStatement$1.run(UiThreadStatement.java:44)
[task 2018-05-25T07:08:30.866Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2018-05-25T07:08:30.866Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-05-25T07:08:30.866Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-05-25T07:08:30.867Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.os.Looper.loop(Looper.java:137)
[task 2018-05-25T07:08:30.867Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2018-05-25T07:08:30.868Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-05-25T07:08:30.868Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-05-25T07:08:30.869Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2018-05-25T07:08:30.869Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2018-05-25T07:08:30.870Z] 07:08:30     INFO -  org.mozilla.geckoview.test | 	at dalvik.system.NativeStart.main(Native Method)
[task 2018-05-25T07:08:30.870Z] 07:08:30     INFO -  org.mozilla.geckoview.test |
[task 2018-05-25T07:08:30.870Z] 07:08:30     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=forCallbacksDuringWait_limitedToLastSessionWait
[task 2018-05-25T07:08:30.871Z] 07:08:30     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2018-05-25T07:08:30.871Z] 07:08:30  WARNING -  TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.GeckoSessionTestRuleTest.forCallbacksDuringWait_limitedToLastSessionWait | status -2
[task 2018-05-25T07:08:30.872Z] 07:08:30     INFO -  TEST-INFO took 16642ms
Component: Testing → GeckoView
Resetting priority from P5 to -- so GeckoView bug triage will see this bug.
Assignee: nobody → nchen
Priority: -- → P2
Comment on attachment 8984338 [details]
Bug 1464351 - Look for initial about:blank load for cached session;

https://reviewboard.mozilla.org/r/250148/#review257754
Attachment #8984338 - Flags: review?(snorp) → review?(esawin)
Comment on attachment 8984338 [details]
Bug 1464351 - Look for initial about:blank load for cached session;

https://reviewboard.mozilla.org/r/250148/#review257930
Attachment #8984338 - Flags: review?(esawin) → review+
Attachment #8984338 - Flags: review?(snorp)
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/359b40c7c268
Look for initial about:blank load for cached session; r=esawin
https://hg.mozilla.org/mozilla-central/rev/359b40c7c268
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Duplicate of this bug: 1466482
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 62 → mozilla62

6c6f5da9-bf33-4082-a19d-7d99e8083d97 Mass rename intermittents due to Bug 1723034.

Summary: Intermittent org.mozilla.geckoview.test.GeckoSessionTestRuleTest.forCallbacksDuringWait_limitedToLastSessionWait | status -2 → Intermittent org.mozilla.geckoview.test.GeckoSessionTestRuleTest#forCallbacksDuringWait_limitedToLastSessionWait | status -2
You need to log in before you can comment on or make changes to this bug.