Closed Bug 1464369 Opened 3 years ago Closed 3 years ago

Pausing and playing an animation will display the properties' scrubber incorrectly

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 disabled, firefox62 affected)

RESOLVED DUPLICATE of bug 1463372
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- disabled
firefox62 --- affected

People

(Reporter: danibodea, Unassigned)

References

(Blocks 1 open bug)

Details

STR:
1. Opne the following page in the browser:
https://rawgit.com/dadaa/3b73f847427025b51ba1ab7333013d0c/raw/77f3f0bb884875a179c3407f73bf8a8dd54751c9/doc_simple_animation.html
2. Open the developer tools Animation Inspector.
3. Pause the animation and play it again.
ER: The animation's property scrubber should continue from where is was paused.
AR: The animation's property scrubber will jump back a little and continue from there.
Reproducible on: Fx62 (20180525005138) with Windows10 64-bit, Windows7 32-bit, Mac OS X 10.12.6, Ubuntu 16.04.
This issue does not occur in the older version of the Animation Inspector, not reproducible in Fx61 (v61.0b7).
Blocks: 1452971
OS: Unspecified → All
Hardware: Unspecified → All
Version: unspecified → Trunk
Summary: pausing and playinh an animation will display the properties scrubber incorrectly → Pausing and playing an animation will display the properties' scrubber incorrectly
Please ignore the steps in the description. 

These are the right STR:
1. Open the following page in the browser:
https://rawgit.com/dadaa/3b73f847427025b51ba1ab7333013d0c/raw/77f3f0bb884875a179c3407f73bf8a8dd54751c9/doc_simple_animation.html
2. Open the Developer Tools Animation Inspector.
3. Select the "ball longhand" div.
4. Pause the animation and play it again.
ER: The animation's property scrubber should continue from where is was paused.
AR: The animation's property scrubber will jump back a little and continue from there.
Thank you for the reporting Bodea.
Though I talked this with Adrian on Slack yesterday, this looks duplicating to bug 1463372.
Could you confirm again after fix the bug?
Priority: -- → P3
+ni for comment 3.
Flags: needinfo?(daniel.bodea)
I talked with Adrian on Slack, and as Bodae commentted in bug 1463372 comment 12, this has been fixed by bug 1463372.
I add a duplicate flag.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(daniel.bodea)
Resolution: --- → DUPLICATE
Duplicate of bug: 1463372
See Also: → 1465044
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.