Last Comment Bug 146459 - HTML mail attachments always inlined
: HTML mail attachments always inlined
Status: VERIFIED DUPLICATE of bug 55657
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: (not reading, please use seth@sspitzer.org instead)
: Trix Supremo
Mentors:
Depends on:
Blocks: 152921
  Show dependency treegraph
 
Reported: 2002-05-23 09:29 PDT by Karsten Opitz
Modified: 2004-11-22 17:25 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Karsten Opitz 2002-05-23 09:29:12 PDT
I receive an e-mail which has several HTML attachments whose content-
disposition is set to "attachment". The HTML pages in turn contain Java 
applets. When I open the mail, all attachments are inlined.
This is quite annoying since all the applets will start running.

RFC 2183 explicitly says (Section 2.2)
"Bodyparts can be designated 'attachment`, ...., and that their display should 
be automatic, but contingent upon some further action of the user.

Mozilla seems to violate this specification.
Comment 1 R.K.Aa. 2002-05-23 22:37:34 PDT
it is possible to set the view:
View->Message Body As-> Original HTML/Simple HTML/Plain Text
Comment 2 Karsten Opitz 2002-05-24 01:15:02 PDT
I can't find the View settings mentioned in comment #1. Using build 
20020510.
This seems to be a workaround at best. The default settings need to work as 
well.
Comment 3 R.K.Aa. 2002-05-24 22:07:11 PDT
this was implemented in bug 69529 / bug 30888 and is not yet on the branch.
Many related bugs are referred to in those.
Comment 4 Ben Bucksch (:BenB) 2002-07-03 13:32:37 PDT
This is a dup of the "view as inline" pref bug.

The new body options might not display the attachment inline, but if so, that's
a bug (per ducarroz, IIRC).
Comment 5 R.K.Aa. 2002-07-28 02:44:49 PDT

*** This bug has been marked as a duplicate of 55657 ***
Comment 6 Trix Supremo 2002-08-02 15:08:54 PDT
verifying dupe

Note You need to log in before you can comment on or make changes to this bug.