Key F6 crashes mozilla

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: hugo van woerkom, Assigned: Matti)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME)

(Reporter)

Description

16 years ago
When mozilla starts and you had the sidebar opened, it will be opened again.
F6 is described in the shortcuts html in 3 ways:
1. page navigation: move to next frame
2. Mail/News: move to next pane
3. Help: move to next pane.
However it also moves between sidebar and mainscreen. Very useful if you have a
bookmark for your root directory. Then the entire file system can be viewed. Like:
Use the up down arrows to move to the right file
Hit enter. (File is viewed in the main screen).
Use F6 to go to that screen for navigation.
Except, AT TIMES, (I don't know exactly when) it crashes mozilla.

Build: 2002052221
Also the source from 5/20 does it.
And since this build is talkback enabled I sent one, but forgot (of course) to
note the ID.

Comment 1

16 years ago
You can check Talkback ID by running 'mozilla/bin/components/talkback/talkback'.
Please post Talkback ID for your crash here.
Keywords: crash, stackwanted
(Reporter)

Comment 2

16 years ago
Talkback IDs:
TB6608436Z
TB6592185E
(Assignee)

Updated

16 years ago
Whiteboard: TB Stack Trace requested from NS

Comment 3

16 years ago
confirmed:
Win2k, sp2 mozilla 1. rc3.

Talkback id:TB6616355G.

Url tested is the drill down mentioned about. To make it easier for everybody,
here is the exact url:
http://www.exact.nl/docs/BDDocument.asp?Action=View&ID={0CC13CC9-7314-43A7-95DF-A44ECA313B6C}&noheader=1&nosubject=1

(Reporter)

Comment 4

16 years ago
Had it on the latest CVS build, but not debug/talkback enabled:
Mozilla 1.0.0+
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020526
(Reporter)

Comment 5

16 years ago
On Mozilla 1.1a
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020609
hitting F6 when this is displayed as a graph:

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 20010904//EN" 
  "http://www.w3.org/TR/2001/REC-SVG-20010904/DTD/svg10.dtd">
<svg width="12cm" height="4cm" viewBox="0 0 1200 400"
     xmlns="http://www.w3.org/2000/svg">
  <desc>Example line01 - lines expressed in user coordinates</desc>

  <!-- Show outline of canvas using 'rect' element -->
  <rect x="1" y="1" width="1198" height="398"
        fill="none" stroke="blue" stroke-width="2" stroke-dasharray="2,2" />

  <g stroke="green" >
    <line x1="100" y1="300" x2="300" y2="100"
            stroke-width="5" stroke-dasharray="2,2"  />
    <line x1="300" y1="300" x2="500" y2="100"
            stroke-width="10"  />
    <line x1="500" y1="300" x2="700" y2="100"
            stroke-width="15"  />
    <line x1="700" y1="300" x2="900" y2="100"
            stroke-width="20"  />
    <line x1="900" y1="300" x2="1100" y2="100"
            stroke-width="25"  />
  </g>
</svg>

Using this html:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
	<body>
		<iframe src="line01.svgz" width="1213px" height="875px" frameborder="0"
MARGINWIDTH="0"  MARGINHEIGHT="0" >
			<embed src="line01.svgz" width="1213px" height="875px" /> 
		</iframe>
	</body>
</html>

Crashes the browser. But the browser versions I will detail in additional comments.
I DO NOT KNOW IF THIS IS THE SAME BUG!!!
(Reporter)

Comment 6

16 years ago
Subsequent to Comment #5:
It does NOT crash using:

 Mozilla 1.0 Release Candidate 11.0.0 Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.0rc1) Gecko/20020425
or:
Mozilla 0.9.9 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313
or:
Mozilla 1.0 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020610
Debian/1.0.0-1
(Assignee)

Comment 7

16 years ago
the Talkback mail to NS seem to be lost.
Reporter:
Can you attach a new TB ID from mozilla 1.1b or later ?
Whiteboard: TB Stack Trace requested from NS

Comment 8

16 years ago
I was able to reproduce comment #5 with Moz 1.1b/Linux
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

1. Installed Adobe's SVG viewer Version 3.0 Beta, Build 77
2. opened the sidebar with a bookmark to files (didn't bother to point it to the   
   html file that opens the svg),
3. opened #5's html file 
4. the SVG image was displayed 
5. I hit F6
6. Moz crashes, I get the talkback dialog

expected:

Moz doesn't crash and focus goes to the sidebar.

The talkback ID is TID TB8837354K

Now, is this a Mozilla bug or a SVG bug?
(Assignee)

Comment 9

16 years ago
>Installed Adobe's SVG viewer Version 
invalid since the plugin is broken in mozilla (they use unfrozen interfaces)
Whiteboard: DUPME

Comment 10

16 years ago
Pressing F6 crashes Mozilla 1.1 rel. I can duplicate by browsing to a PDF doc,
opening an extra tab on an HTML doc, returning to the PDF tab, and pressing F6 a
couple of times.
(Assignee)

Comment 11

16 years ago
wronkiew@foozone.org  : Please add a talkback ID from a recent build (1.2b or later)
(Assignee)

Comment 12

15 years ago
-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.