Closed Bug 1464639 Opened 2 years ago Closed 2 years ago

Intermittent application crashed [@ JSPurpleBuffer::cycleCollection::Trace]

Categories

(Core :: JavaScript: GC, defect, P5)

Unspecified
Android
defect

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: peterv)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=180420947&repo=mozilla-central

https://queue.taskcluster.net/v1/task/RlfG1waZQj6LK2r_h2xCIA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-05-26T23:15:29.280Z] 23:15:29     INFO -  TEST-START | services/common/tests/unit/test_remote_settings.js
[task 2018-05-26T23:15:48.131Z] 23:15:48  WARNING -  TEST-UNEXPECTED-FAIL | services/common/tests/unit/test_remote_settings.js | xpcshell return code: 139
[task 2018-05-26T23:15:48.131Z] 23:15:48     INFO -  TEST-INFO took 18851ms
[task 2018-05-26T23:15:48.132Z] 23:15:48     INFO -  >>>>>>>
[task 2018-05-26T23:15:48.133Z] 23:15:48     INFO -  services/common/tests/unit/test_remote_settings.js | xpcw: cd /sdcard/tests/xpc/services/common/tests/unit
[task 2018-05-26T23:15:48.134Z] 23:15:48     INFO -  services/common/tests/unit/test_remote_settings.js | xpcw: xpcshell -r /sdcard/tests/xpc/c/httpd.manifest --greomni /data/local/xpcb/target.apk -m -s -e const _HEAD_JS_PATH = "/sdcard/tests/xpc/head.js"; -e const _MOZINFO_JS_PATH = "/sdcard/tests/xpc/p/mozinfo.json"; -e const _TESTING_MODULES_DIR = "/sdcard/tests/xpc/m"; -f /sdcard/tests/xpc/head.js -e const _SERVER_ADDR = "localhost" -e const _HEAD_FILES = ["/sdcard/tests/xpc/services/common/tests/unit/head_global.js", "/sdcard/tests/xpc/services/common/tests/unit/head_helpers.js", "/sdcard/tests/xpc/services/common/tests/unit/head_http.js"]; -e const _JSDEBUGGER_PORT = 0; -e const _TEST_FILE = ["test_remote_settings.js"]; -e const _TEST_NAME = "services/common/tests/unit/test_remote_settings.js" -e _execute_test(); quit(0);
[task 2018-05-26T23:15:48.134Z] 23:15:48     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2018-05-26T23:15:48.135Z] 23:15:48     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2018-05-26T23:15:48.137Z] 23:15:48     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2018-05-26T23:15:48.137Z] 23:15:48     INFO -  running event loop
[task 2018-05-26T23:15:48.137Z] 23:15:48     INFO -  services/common/tests/unit/test_remote_settings.js | Starting test_records_obtained_from_server_are_stored_in_db
[task 2018-05-26T23:15:48.137Z] 23:15:48     INFO -  (xpcshell/head.js) | test test_records_obtained_from_server_are_stored_in_db pending (2)
[task 2018-05-26T23:15:48.137Z] 23:15:48     INFO -  services/common/tests/unit/test_remote_settings.js | JavaScript strict warning: resource://services-common/kinto-http-client.js, line 1639: ReferenceError: reference to undefined property "initializer"
[task 2018-05-26T23:15:48.138Z] 23:15:48     INFO -  services/common/tests/unit/test_remote_settings.js | JavaScript strict warning: resource://services-common/kinto-http-client.js, line 1102: ReferenceError: reference to undefined property "initializer"
[task 2018-05-26T23:15:48.139Z] 23:15:48     INFO -  services/common/tests/unit/test_remote_settings.js | JavaScript strict warning: resource://services-common/kinto-http-client.js, line 347: ReferenceError: reference to undefined property "initializer"
[task 2018-05-26T23:15:48.139Z] 23:15:48     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2018-05-26T23:15:48.140Z] 23:15:48     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "initializer"" {file: "resource://services-common/kinto-http-client.js" line: 1639}]"
[task 2018-05-26T23:15:48.141Z] 23:15:48     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "initializer"" {file: "resource://services-common/kinto-http-client.js" line: 1102}]"
[task 2018-05-26T23:15:48.142Z] 23:15:48     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "initializer"" {file: "resource://services-common/kinto-http-client.js" line: 347}]"
[task 2018-05-26T23:15:48.142Z] 23:15:48     INFO -  services/common/tests/unit/test_remote_settings.js | JavaScript strict warning: resource://services-common/kinto-http-client.js, line 543: ReferenceError: reference to undefined property "headers"
[task 2018-05-26T23:15:48.143Z] 23:15:48     INFO -  services/common/tests/unit/test_remote_settings.js | JavaScript strict warning: resource://services-common/kinto-http-client.js, line 1161: ReferenceError: reference to undefined property "headers"
[task 2018-05-26T23:15:48.144Z] 23:15:48     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "NetworkError when attempting to fetch resource." {file: "/sdcard/tests/xpc/head.js" line: 215}]
[task 2018-05-26T23:15:48.144Z] 23:15:48     INFO -  _do_main@/sdcard/tests/xpc/head.js:215:3
[task 2018-05-26T23:15:48.145Z] 23:15:48     INFO -  _execute_test@/sdcard/tests/xpc/head.js:522:5
There are some instances of this for telemetry and services/ tests - converting this to a general bug.
Component: Firefox: Common → JavaScript: GC
Flags: needinfo?(jdemooij)
Product: Cloud Services → Core
Summary: Intermittent services/common/tests/unit/test_remote_settings.js | xpcshell return code: 139 → Intermittent application crashed [@ JSPurpleBuffer::cycleCollection::Trace]
Hmm, haven't been able to reproduce locally :-(.
So this is probably an existing issue that just got exposed because we started running the CC in xpcshell tests. I pushed some logging to tryserver to figure out what's going on.
Duplicate of this bug: 1464901
Duplicate of this bug: 1465183
(In reply to Peter Van der Beken [:peterv] from comment #8)
> Hmm, haven't been able to reproduce locally :-(.
Only affects Android.
OS: Unspecified → Android
Assignee: nobody → peterv
Status: NEW → ASSIGNED
Flags: needinfo?(peterv)
Attachment #8981892 - Flags: review?(bugs)
Attachment #8981892 - Flags: review?(bugs) → review+
Attachment #8981892 - Flags: review+
Duplicate of this bug: 1465526
Duplicate of this bug: 1466012
Duplicate of this bug: 1466005
Duplicate of this bug: 1465984
Duplicate of this bug: 1465959
https://hg.mozilla.org/mozilla-central/rev/3567106d0a05
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Duplicate of this bug: 1466280
You need to log in before you can comment on or make changes to this bug.