Open Bug 1464792 Opened 2 years ago Updated 7 months ago

pressing buttons or checkboxes shows text selection overlay

Categories

(Firefox for Android :: Text Selection, defect)

All
Android
defect
Not set

Tracking

()

REOPENED
Tracking Status
fennec ? ---

People

(Reporter: felix.bau, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(16 files)

User Agent: Mozilla/5.0 (Android 7.0; Mobile; rv:60.0) Gecko/60.0 Firefox/60.0
Build ID: 20180515214401

Steps to reproduce:

I touched/clicked certain input elements on some web pages:
https://voice.mozilla.org/en
github.com
https://www.whatsapp.com/legal/


Actual results:

Fennec showed the text selection interface.


Expected results:

there was no text to select and I didn't do press&hold, so it shouldn't have displayed the interface.
Attached image common voice 1
after pressing the disabled yes button
Attached image common voice 2
after pressing disabled no button
Attached image common voice 3
after listening to a voice sample and pressing the enabled yes button
ups, I mixed up the descriptions of common voice 1 + 3 (just swap them in your mind)

I reproduced these in the nightly, but made the screenshots in Release.
Attached image Amazon.com 1
when pressing the x button you see the interface appear for a brief moment
(select all)
Attached image Amazon.com 2
I somehow managed to even get this to appear by pressing x and then on the greed out background, I think. (also only a brief moment)
it's not a new regression (months in release) but I somehow forgot to report it back then.
I thought I did it until this morning, but that was another bug.

I'm not sure what triggers the bug, yet.
Maybe buttons that execute javascript?

YouTube and Amazon are also affected.
Attached image YouTube.com 1
Attached image YouTube.com 2
OS: Unspecified → Android
Hardware: Unspecified → All
I did some bisecting:
last nightly before the regression:
https://archive.mozilla.org/pub/mobile/nightly/2015/12/2015-12-03-05-35-21-mozilla-central-android-api-11/

first nightly with the regression:
https://archive.mozilla.org/pub/mobile/nightly/2015/12/2015-12-04-03-02-08-mozilla-central-android-api-11/

They are so old and have other bugs that I'm not able to demonstrate the bug on common voice and github, but whatsapp, Amazon.com and YouTube still work/show the bug just fine.
My guess is, that it's part of one of the two big merge commits here (filtered by folder):
https://github.com/mozilla/gecko-dev/commits/master@%7B2015-12-04T03:02:08Z%7D/mobile
Mercurial pushlog (not filtered by folder):
https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2015-12-03+05%3A35%3A21&enddate=2015-12-04+03%3A02%3A08

I can't tell from the commit messages, which commit might have affected how firefox for android handles text selection/buttons.

I tried compiling manually to find the actual commit, but can't because the build requires OpenJDK 7, which isn't available anymore with apt in Ubuntu.

I used:
git bisect start c40454e094856a75a4bc33f1683bce1efeb59751 5c14ea4c04f88d5e5d5a2c15ca7252649f0e3569
for that
Thanks for report.

I tried with this devices: LG G4 (Android 5.1), Motorola Nexus 6 (Android 7.1.1), Samsung Galaxy Note 8 (Android 8.0.0) on all branches(Nightly 62.0a1; Beta 61.0b9; Release 60.0.1;) and I can reproduce the issue following the steps from description.
I will put this bug as new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached image Festify.us 1
the issue is even more obvious with
https://festify.us/

clicking the logo does nothing in Chrome, but it opens the text selection in Firefox
Attached image Festify.us 2
tracking-fennec: --- → ?
This issue seems to be duplicate of bug 1286882. I will mark this as duplicate of other, please follow the discussion there.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1286882
This bug hasn't been fixed completely by 1286882

Amazon and Common Voice are still affected (see attached screenshots of the text selection)
I confirmed this in Nightly 63.0a1 (2018-07-16)

At least Common Voice doesn't involve an svg as far as I can see.
Just "yes" and "no" on buttons.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
It looks like both the Amazon and Common Voice are clicking something inside a "display: flex;" container. A grid container might have a similar issue.

I guess adding "aFrame->IsFlexOrGridContainerFrame()" in the if-statement in [1] could fix this. I'm not sure whether it's a good idea for the moment.

[1] https://dxr.mozilla.org/mozilla-central/rev/085cdfb90903d4985f0de1dc7786522d9fb45596/layout/generic/nsFrame.cpp#4756
this bug isn't fixed, yet.
I stumbled on a new example where this happens
https://youtu.be/DyoOcbd20go

(recorded on Android 7 with the current nightly)

https://www.heise.de/mac-and-i/meldung/Bis-zu-2-8-GByte-s-Samsung-fuehrt-kompakte-Thunderbolt-3-SSD-X5-ein-4148457.html
Attached image Twitter
and twitter
Attached image Instagram

Instagram is also affected
https://www.instagram.com/rampagebelgium/

See Also: → 1516963
Attached image another example

https://grg.de/referenzen/Mercedes-Benz-Arena-38.htm

if you press and hold on the image (like for saving), then this shows up instead of the image dialog.

they probably did some div magic/voodoo to "protect the image" (transparent div covering the image)
still: the carets shouldn't show up

Attached image dhl.de

The custom checkboxes on the website of DHL (German postal service) are also affected.
(this page is only reachable for customers, but they likely use those checkboxes elsewhere, too)

Djfe, thanks for keeping posting websites that don't work as expected. Bug 1516963 should fix most of the issues in this thread that the blue carets appears by single clicking on something in flex or grid layout (like comment 20 and comment 22).

thx for the update :)
I'm glad this is getting fixed

4 of the mentioned pages are still affected in nightly
https://youtu.be/OBzymtNw_hs

sometimes you have to click/tap it fast (heise and Twitter) or press and hold (grg.de) to make them show up

on toneden.io one tap on the deactivated button is enough

Duplicate of this bug: 1546272
You need to log in before you can comment on or make changes to this bug.