Setting bgcolor attribute on document body doesn't work.

VERIFIED DUPLICATE of bug 1886

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 1886
19 years ago
17 years ago

People

(Reporter: bijals (gone), Assigned: troy)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Steps:
1) Launch Editor
2) Set background color from icon to red
3) Click the same icon and choose another color

Actual Results: no change from red to the new color

Expected Results: New color should be set as page background

Build Date and Platform: 1999092208 on WinNT

Updated

19 years ago
Assignee: buster → cmanske

Comment 1

19 years ago
charley, can you do the initial eval of this problem?

Comment 2

19 years ago
Created attachment 1823 [details]
Test setting doc background color

Updated

19 years ago
Assignee: cmanske → troy
Summary: Could not change a background color after setting it once → Setting bgcolor attribute on document body doesn't work.

Comment 3

19 years ago
This will probably be found by normal DOM testing.
I've attached a test file that you can load in viewer.
In viewer, the color isn't set at all. In editor, it seems to set it the first
time we call the body tag's setAttribute("bgcolor", <color>), but not on
subsequent calls.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Depends on: 1886
Resolution: --- → DUPLICATE

Comment 4

19 years ago
*** This bug has been marked as a duplicate of 1886 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
verified in 9/23 build.
You need to log in before you can comment on or make changes to this bug.