Code bypasses "Open Unrequested Windows" preference

VERIFIED DUPLICATE of bug 126224

Status

VERIFIED DUPLICATE of bug 126224
17 years ago
14 years ago

People

(Reporter: yippiezippie, Assigned: Matti)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

The JS code in the ad linked above somehow bypasses the preference for no pop-up
windows.  If you place this code in a blank HTML document you get a pop-up ad,
even if the preference is turned off.  I will update if I am able to determine
what is unique about this code that makes it function this way.

Reproducible: Always
Steps to Reproduce:
1. Compose a blank HTML document.
2. Download the JS code from
http://ad.doubleclick.net/adj/N339.glispa/B939866.4;abr=!ie;sz=720x300;ord=[timestamp]
3. Put this code in the document, enclose in script tags.
4. On page load, an unrequested advertisement window will open.

Actual Results:  I should have not seen the pop-up advertisement.

Expected Results:  Mozilla should have suppressed the pop-up window.

This ad was originally encountered at http://www.ucomics.com, and the
advertisement is for trip.com.  If you reload ucomics.com enough times you
should also be able to see the pop-up ad.

Comment 1

17 years ago
The problem is that the popup is created from the onLoad of the image.

Adding this pref to your user.js file should fix the problem:
user_pref("dom.disable_open_click_delay", 1000); 

*** This bug has been marked as a duplicate of 126224 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.