tab autocomplete fails on nicks with characters other than \w

RESOLVED DUPLICATE of bug 146509

Status

Other Applications
ChatZilla
RESOLVED DUPLICATE of bug 146509
16 years ago
14 years ago

People

(Reporter: Giscard Girard, Assigned: Robert Ginda)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
If someone has a nick like [rgindaisgay] typing

hello [rgin<tab>

would not match the nick.
(Reporter)

Comment 1

16 years ago
Created attachment 84797 [details] [diff] [review]
changes the regexp /\s\w*$/ to /\s\S*$/

var wordStart = line.substr(0, selStart).search(/\s\w*$/);

in onTabCompleteRequest

becomes

var wordStart = line.substr(0, selStart).search(/\s\S*$/);

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 146509 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.