mozilla process uses 100% CPU utilization and must be killed

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: brossard, Assigned: karnaze)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

When trying to go to website www.caldrives.com 100% of the CPU is used by
mozilla. Not sure why

Reproducible: Always
Steps to Reproduce:
1. open mozilla (the best browser in the world)
2. (try to) go to URL www.caldrives.com
3.

Actual Results:  mozilla is frozen and tries to use 100% of cpu

Expected Results:  in IE it pulls up a web page.

Comment 1

17 years ago
confirmed: 2002051006 - win98
The problem is that caldrives.com loads a 118kb page with 100 forms nested in
two tables. And each form is located in the tr, not the td. Once this page has
been loaded it immediately redirects to either
http://www.caldrives.com/index-g4speaker.html or
http://www.caldrives.com/index-zipang.html

Basically this first page seems to be nothing more than a malicious page
designed to fool search engines, but it sure is bringing Mozilla to a halt for
up to 30 seconds or so.

Mozilla is getting noticeably slow starting with 25 forms, and the amount of
time Mozilla seems to 'hang' increases steadily.

Removing the outer table fixes the problem, so changing component to HTML
Tables. The problem seems to be mostly caused by the huge amount of data to load
and display - creating a testpage with nearly empty forms in otherwise empty
tables doesn't give any problems.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Actually reassigning to HTMLTables
Assignee: Matti → karnaze
Component: Browser-General → HTMLTables
QA Contact: imajes-qa → amar

Comment 3

17 years ago
Created attachment 84811 [details]
offending caldrives.com page - will stall mozilla for >30 sec

Attaching the source of the offending page as this'll save someone half a
minute of firing up another browser to capture it.

Comment 4

17 years ago
 The given URL does not hang anymore with the recent branch build: 2002061408. 
WIN2K. Marking WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.