Closed Bug 1465020 Opened Last year Closed Last year

Font editor shows empty values

Categories

(DevTools :: Inspector: Fonts, defect, P2)

defect

Tracking

(firefox62 fixed)

RESOLVED FIXED
Firefox 62
Tracking Status
firefox62 --- fixed

People

(Reporter: mbalfanz, Assigned: rcaliman)

References

Details

(Whiteboard: [good first verify])

Attachments

(2 files)

Attached video empty-values.mp4
On some fonts, the font editor shows empty values / input fields by default.

STR:
1. go to v-fonts.com
2. look for the font "Buffalo Gals"
3. inspect the fonts and check the font editor

Expected result:
- all fields should be pre-populated with the applied values

Actual result:
- some fields have values, some don't, even though everything is set in the computed view

The attached video shows two examples.
Assignee: nobody → rcaliman
Status: NEW → ASSIGNED
This happens because the custom axes include intentional whitespace, "CK  ", "HR  ", "HV  " (tags must be 4 characters long) that gets trimmed when parsing the axis tag names.

See: https://searchfox.org/mozilla-central/source/devtools/client/inspector/fonts/reducers/font-editor.js#83

The parse method should not trim whitespace from tag names.
Comment on attachment 8983449 [details]
Bug 1465020 - Do not trim whitespace from variable font axis tag names.

https://reviewboard.mozilla.org/r/249286/#review255488
Attachment #8983449 - Flags: review?(gl) → review+
Pushed by rcaliman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/74fded5d5a6b
Do not trim whitespace from variable font axis tag names. r=gl
https://hg.mozilla.org/mozilla-central/rev/74fded5d5a6b
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Product: Firefox → DevTools
Duplicate of this bug: 1465021
You need to log in before you can comment on or make changes to this bug.