Update mode 2/3 "default route" to use the interface used to reach the origin

RESOLVED DUPLICATE of bug 1506219

Status

()

enhancement
P3
normal
Rank:
35
RESOLVED DUPLICATE of bug 1506219
Last year
2 months ago

People

(Reporter: bwc, Unassigned)

Tracking

60 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

draft-ietf-rtcweb-ip-handling now specifies that the "default route" is the route used to reach the origin, and we need to update our code to do this.
Duplicate of this bug: 1464863
Rank: 35
Priority: -- → P3

To elaborate, this is an issue in networks that have configured a route for the origin different from the default route. What happens is that Firefox picks the IP address of the default route's interface and uses it as its source IP address. But then the OS sends it via the route that has been configured for the destination IP address. The destination network will then discard the packet since the source IP address does not lie within its network. If that's a bit confusing, basically it boils down to this:

Default Route's Interface (1) has address (A).
Other Interface (2) has address (B).
Origin has been fetched via (2).
Firefox picks (A) but it's being sent via (2).

The result is that if STUN and TURN servers are reachable via (2), no srflx or relay candidates can be gathered, limiting the application to host candidates.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1506219
You need to log in before you can comment on or make changes to this bug.