If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

gartner.com - login popup does not appear

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: dave, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0+)
Gecko/20020523
BuildID:    2002052304

Popup window (Click 'sign in', top right) when signing into www.gartner.com
doesnt appear.



Reproducible: Always
Steps to Reproduce:
1. Go to www.gartner.com
2. Click 'sign in' next to 'current user:'
3. Pop-up window should appear asking for username and pass.

Actual Results:  Nothing

Expected Results:  Sign in pop up should appear

Bad javascript on their part?
Works with IE6.
Here are some snippets of their html:
<td  valign-middle width="122"  height="20" valign="middle" class="buttonDescribe">
<img height="1" width="12" src="/images/trans_pixel.gif"  vspace="0" hspace="0" />
Current Users
</td>

<td class="whiteBack" valign-middle width="90" height="24" valign="middle">
<a href="javascript:void(null)"
onclick="openSigninPopup('SigninPopup.jsp?call=homepage')">
<img src="/images/homepage/sign_in.gif" border="0" height="24" width="70"
vspace="0" hspace="0">
</a>
</td>

Comment 1

16 years ago
i get 3 js errors when loading the page:

Error: closeLogin is not defined
Error: uncaught exception: Permission denied to set property Window.fullScreen
Error: uncaught exception: Permission denied to set property Window.fullScreen

and then one when clicking "sign in" button:

Error: openSigninPopup is not defined
(Reporter)

Comment 2

16 years ago
The function 'openSigninPopup ' is defined in another file, pulled in by this 
line:
	
	<script src="/js/utility.js"></script>
	
It looks like this:

function openSigninPopup(href) {

   var iMyLeft;
   var iMyTop;
   var sWinStr;
   //gets top and left positions based on user's resolution so hint window is 
centered.
   iMyLeft = (window.screen.width/2) - (140 + 10); //half the screen width 
minus half the new window width (plus 5 pixel borders).
   iMyTop = (window.screen.height/2) - (135 + 27); //half the screen height 
minus half the new window height (plus title and status bars).
   sWinStr="left=" + iMyLeft + ",top=" + iMyTop + ",screenX=" + iMyLeft 
+ ",screenY=" + iMyTop;

   self.name = nameForWindow('homepage');
   
   signinPopup = window.open(href+'&parentWindow='+self.name,'LoginPopup', 
sWinStr + ',height=275,width=280,scrollbars=no,menubar=no');

   var killPopup = setTimeout("signinPopup.close()", 180000);
}

I guess either 
   mozilla isnt finding the openSigninPopup source  because it is loaded in 
some IE specific or non-standard manner
   or the openSigninPopup source is broken / IE specific

---NB: I dont know anything about javascript!
(Reporter)

Comment 3

15 years ago
Seems to be related to bug 153432

Comment 4

15 years ago
Moving to evangelism
Assignee: sgehani → doron
Component: XP Apps → US General
Product: Browser → Tech Evangelism
QA Contact: paw → zach
Version: other → unspecified

Comment 5

15 years ago
Onload, the following appears twice in the JavaScript Console:
Error: uncaught exception: Permission denied to set property Window.fullScreen

When I click "SIGN IN," loading of the page stops and the following appears in
the JavaScript Console:
Error: openSigninPopup is not defined

If I refresh the page, I get, along with the original two errors again,:
Error: closeLogin is not defined

This does look like a duplicate of bug 153432.

Information from bug 153432:
------- Additional Comment #2 From Phil Schwartau  2002-06-21 15:07 -------

The problem is, in view-source:http://www4.gartner.com/js/utility.js,
the site authors define a function called |fullScreen|:

function fullScreen(theURL)
{
 newWin = window.open(theURL, '', 
                      'fullscreen=yes,scrollbars=auto,status=yes,menubar=yes');
 storeNewWin(newWin);
 return false;
}


This name, as all function names, enters the global JS namespace.
In the DOM, that means the |window| namespace. But there is ALREADY
a global identifier with this name: |window.fullScreen|.

That's why, when we load this site in Mozilla, we see this error
in the JavaScript Console:

           Error: uncaught exception:
           Permission denied to set property Window.fullScreen


So in Mozilla, the function fullScreen() remains undefined, and so
do all functions defined after it in the utility.js file. (Just load
the site in the Mozilla JS Debugger; you won't see any functions
appearing in the File View after the function openNewSubAdminFooter()).

That's why the "Contact Us" link fails: it depends on one of these
missing functions...

Reassigning to DOM Level 0. Should site authors be able to name
a global function "fullScreen"? 


------- Additional Comment #3 From Christian Eyrich 2002-06-21 15:48 -------

Phil, who defined the already existing window.fullScreen and where? Not the
sites author obviously, is it a Mozilla internal thing?
However, fullScreen is a not seldom used name for a fullScreen window function,
so to prohibit authors to use this function name seems not very wise to me.


------- Additional Comment #4 From Phil Schwartau 2002-06-21 16:29 -------

Christian: I'll have to let the DOM experts answer that one.
There is, (or was), a native DOM property |window.fullScreen|.

See bug 127405, "Scripts can put a window in fullscreen mode"
Looks like it used to be there, but access to it has been disabled
for security reasons...(?)
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Javascript Pop-up doesn't appear → gartner.com - login popup does not appear

Comment 6

15 years ago
*** Bug 153432 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
cc'ing jst to make sure this is an Evangelism bug - ? The site authors
have defined a global function fullScreen(), which causes the error

          Error: uncaught exception:
          Permission denied to set property Window.fullScreen

Is this our fault or theirs?

Note bug 127405, "Scripts can put a window in fullscreen mode".
Looks like |window.fullScreen| used to be there, but access
to it has been disabled for security reasons...(?)

Another question: why does the error message say |Window|
with a capital "W", and not |window| ?

Comment 8

15 years ago
cc'ing jst for real this time; see my question in Comment #7.
Also cc'ing mstoltz -
(Reporter)

Comment 9

15 years ago
Sent the following message to Gartner's site feedback form:

Hi -

I use GartnerWeb to keep myself up to date on developing issues in Network and
Systems management and find that you have a lot of interesting articles. 

I have a problem with your site when trying to log-in. When I click the
'sign-in' button on the front page, the sign-in pop-up box doesnt appear.

I am using the Mozilla  web browser. (www.mozilla.org) A standards compliant,
cross platform browser popular with technical users on Windows and especially
Solaris and Linux platforms. Netscape will shortly be releasing their version 7
 web browser based on mozilla technology and it too will be impacted by this
problem.

This has the unfortunate side-effect of locking out most Linux / Solaris users -
who are often users with highly experienced IT backgrounds.

This appears to be due to a JavaScript error on the page. Further technical
information can be found at the following link, where Mozilla engineers have
been tracking the problem:

http://bugzilla.mozilla.org/show_bug.cgi?id=146507

Thanks very much for your attention to this matter. Otherwise you have a very
easy to use site.

Dave Goodwin
Consultant
KPMG Consulting
(Reporter)

Comment 10

15 years ago
Hi

i am now able to log into Gartner with no problem (Using Moz 1.1b Build:
2002072104) on WinXP. I expect the problem is completely resolved and this
ticket can be closed. I will send a thank you to Gartner

dave
(Reporter)

Comment 11

15 years ago
Also still working fine under Moz1.1 on WinXP.I suggest this bug is closed

I was asked by Gartner to fill out a survey. I left this comment:

I'd like to thank Gartner for their fast response to upgrading
their website so that it supports Web standards and the Mozilla
Web browser.
(See http://bugzilla.mozilla.org/show_bug.cgi?id=146507)

Comment 12

15 years ago
WFM, 1.0 Mozilla on Win32 marking as such. Please email Gartner thanks.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.