bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

nsSocket.cpp does not compile with gcc 3.1 on sparc solaris 8 with 64bit optimizations

VERIFIED DUPLICATE of bug 102118

Status

SeaMonkey
Installer
VERIFIED DUPLICATE of bug 102118
16 years ago
14 years ago

People

(Reporter: Frank Belew, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
/usr/local/bin/g++ -o nsSocket.o -c -DOSTYPE=\"SunOS5\" -DOSARCH=\"SunOS\" -DOJI
  -I../../../../dist/include/xpnet -I../../../../dist/include
-I/home/frb/build-buddy/ximian-desktop/mozilla/BUILD/mozilla/dist/include/nspr 
    -I/usr/openwin/include   -fPIC  -I/opt/gnome/include
-I/opt/gnome/include/db3  -I/usr/openwin/include -fno-rtti -fno-exceptions
-Wno-long-long -fshort-wchar -pthreads  -DNDEBUG -DTRIMMED -m64 -mtune=v9
-mcpu=v9 -O2 -pipe  -I/opt/gnome/include -I/opt/gnome/include/db3 
-I/usr/openwin/include -DMOZILLA_CLIENT -include ../../../../config-defs.h
-Wp,-MD,.deps/nsSocket.pp nsSocket.cpp
<command line>:1:1: warning: "__WCHAR_TYPE__" redefined
<command line>:1:1: warning: this is the location of the previous definition
nsSocket.cpp: In member function `int nsSocket::SrvAccept()':
nsSocket.cpp:247: invalid conversion from `int*' to `socklen_t*'
nsSocket.cpp: In member function `int nsSocket::GetHostPortString(char**)':
nsSocket.cpp:456: invalid conversion from `int*' to `socklen_t*'
make[1]: *** [nsSocket.o] Error 1


The important lines are the invalid conversions
I tracked this down to the following code in nsSocket.cpp

#if defined(SOLARIS) || defined(_WINDOWS) || defined(IRIX) 
#define socklen_t int
#endif

If I comment this out, this component builds fine

% gcc -v
Reading specs from /usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.1/specs
Configured with: ../configure --enable-languages=c,c++
Thread model: posix
gcc version 3.1

% uname -a
SunOS pedant 5.8 Generic_108528-13 sun4u sparc
(Assignee)

Comment 1

16 years ago
Duplicate of bug 102118, but that's been fixed -- how old is your source?

*** This bug has been marked as a duplicate of 102118 ***
Severity: blocker → normal
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v dupe
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
Its 0.9.9, since I don't have time to deal with Release Candidates right now
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.