Closed Bug 1465490 Opened 4 years ago Closed 3 years ago

[VirtualizedTree] Several elements are not displayed after vertically resizing the "Properties" panel

Categories

(DevTools :: Accessibility Tools, defect)

defect
Not set
minor

Tracking

(firefox-esr60 unaffected, firefox60 unaffected, firefox61 affected, firefox62 affected)

RESOLVED WORKSFORME
Tracking Status
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- affected
firefox62 --- affected

People

(Reporter: emilghitta, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Resize.gif
[Affected versions]:
Firefox 62.0a1 (BuildId:20180529220039).
Firefox 61.0b9 (BuildId:20180528091514).

[Affected platforms]:
Windows 10 64bit.
macOS 10.12.
Ubuntu 16.04 64bit.

[Steps to reproduce]:
1. Launch Firefox.
2. Access any website.
3. Enable the Accessibility features.
4. Expand several elements from the "Properties" panel.
5. Dock the "Developer Tools" panel to side.
6. Vertical drag the "Properties" panel in order to display all the available information.

[Expected result]:
The panel displays all the elements successfully.

[Actual result]:
Some elements are not displayed inside the "Properties" panel. 

[Regression range]:
I don't think that this is a regression.

[Additional information]:
For further information regarding this issue please observe the attached screencast.
Product: Firefox → DevTools

@Emil: I can't reproduce the problem on my machine (Win10)
Are you still seeing the issue?

Honza

Flags: needinfo?(emil.ghitta)
Component: Shared Components → Accessibility Tools

I am no longer able to reproduce this issue using Firefox 68.0a1 (BuildId:20190506214617) on Windows 10 64bit, macOS 10.12.6 and Ubuntu 18.04 64bit.

This issue seems to be fixed by Bug 1518487 (per mozregression output):

10:53.74 INFO: First good revision: 090304ca37d9bfc7846faa11f931ed41ad345b92
10:53.74 INFO: Last bad revision: 586348ccba9b17bcbf7279dff4ca6f8b7a0cc4df
10:53.74 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=586348ccba9b17bcbf7279dff4ca6f8b7a0cc4df&tochange=090304ca37d9bfc7846faa11f931ed41ad345b92

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(emil.ghitta)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.