9.22 - 16.95% tps / tsvgx (windows10-64) regression on push 85572fbd667360384b63a29a2d7ac0bf1285658d (Tue May 29 2018)

VERIFIED FIXED in Firefox 62

Status

()

defect
VERIFIED FIXED
Last year
Last year

People

(Reporter: jmaher, Assigned: aosmond)

Tracking

(Blocks 1 bug, {perf, regression, talos-regression})

unspecified
mozilla62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62 fixed)

Details

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=85572fbd667360384b63a29a2d7ac0bf1285658d

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 17%  tsvgx windows10-64 opt e10s stylo     148.13 -> 173.24
  9%  tps windows10-64 pgo e10s stylo       13.63 -> 14.91
  9%  tps windows10-64 opt e10s stylo       14.87 -> 16.24


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=13541

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: General → Image Blocking
Product: Testing → Core
Investigated this with mstange, looks like I broke the optimizer for single frame GIFs with the last part in my bug. I'll correct this.
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Let's make sure backing out part 9 resolves this. There are some optimizations related to this that I will explore in bug 1465619 now that it is obvious to me what a win optimizing the surfaces on Windows will give (this bug/regression aside, we only optimize frames if the image isn't animated, but if we are blending off the main thread, and we don't enter discard mode, we could easily optimize the frames and maybe get a big win?):

try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=74ef59c3ad38e26cb6e9dee47829582bafdebd02
Component: Image Blocking → ImageLib
Pushed by aosmond@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c8429320386e
Backout part 9 of bug 1462355 to fix talos regressions. r=aosmond
https://hg.mozilla.org/mozilla-central/rev/c8429320386e
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
All reported regressions have been fixed:

== Change summary for alert #13575 (as of Wed, 30 May 2018 20:35:56 GMT) ==

Improvements:

 14%  tsvgx windows10-64 pgo e10s stylo     165.39 -> 142.30
 14%  tsvgx windows10-64 opt e10s stylo     174.64 -> 150.97
 11%  tps windows10-64 pgo e10s stylo       14.72 -> 13.17
 10%  tps windows10-64 opt e10s stylo       16.20 -> 14.60

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=13575
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.