Intermittent netwerk/test/unit/test_trr.js | onLookupComplete - [onLookupComplete : 148] false == true

RESOLVED DUPLICATE of bug 1542561

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 1542561
Last year
5 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-triaged])

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=180912314&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/JlvQnqI1SL66wzSlpVzTpA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-05-30T14:24:06.430Z] 14:24:06     INFO -  PID 14275 | starting test 12
[task 2018-05-30T14:24:06.431Z] 14:24:06     INFO -  (xpcshell/head.js) | test pending (2)
[task 2018-05-30T14:24:06.432Z] 14:24:06     INFO -  PID 14275 | test confirmationNS, retry until the confirmed NS works
[task 2018-05-30T14:24:06.433Z] 14:24:06     INFO -  PID 14275 | Waiting for 1::ffff but got undefined
[task 2018-05-30T14:24:06.435Z] 14:24:06     INFO -  TEST-PASS | netwerk/test/unit/test_trr.js | onLookupComplete - [onLookupComplete : 147] true == true
[task 2018-05-30T14:24:06.435Z] 14:24:06     INFO -  (xpcshell/head.js) | test finished (2)
[task 2018-05-30T14:24:06.435Z] 14:24:06     INFO -  PID 14275 | starting test 12
[task 2018-05-30T14:24:06.435Z] 14:24:06     INFO -  (xpcshell/head.js) | test pending (2)
[task 2018-05-30T14:24:06.435Z] 14:24:06     INFO -  PID 14275 | test confirmationNS, retry until the confirmed NS works
[task 2018-05-30T14:24:06.435Z] 14:24:06     INFO -  PID 14275 | Waiting for 1::ffff but got undefined
[task 2018-05-30T14:24:06.436Z] 14:24:06     INFO -  TEST-PASS | netwerk/test/unit/test_trr.js | onLookupComplete - [onLookupComplete : 147] true == true
[task 2018-05-30T14:24:06.437Z] 14:24:06     INFO -  (xpcshell/head.js) | test finished (2)
[task 2018-05-30T14:24:06.437Z] 14:24:06     INFO -  PID 14275 | starting test 12
[task 2018-05-30T14:24:06.438Z] 14:24:06     INFO -  (xpcshell/head.js) | test pending (2)
[task 2018-05-30T14:24:06.443Z] 14:24:06     INFO -  PID 14275 | test confirmationNS, retry until the confirmed NS works
[task 2018-05-30T14:24:06.445Z] 14:24:06     INFO -  PID 14275 | Waiting for 1::ffff but got undefined
[task 2018-05-30T14:24:06.446Z] 14:24:06  WARNING -  TEST-UNEXPECTED-FAIL | netwerk/test/unit/test_trr.js | onLookupComplete - [onLookupComplete : 147] false == true
[task 2018-05-30T14:24:06.447Z] 14:24:06     INFO -  /builds/worker/workspace/build/tests/xpcshell/tests/netwerk/test/unit/test_trr.js:onLookupComplete:147
[task 2018-05-30T14:24:06.448Z] 14:24:06     INFO -  /builds/worker/workspace/build/tests/xpcshell/head.js:_do_main:215
[task 2018-05-30T14:24:06.449Z] 14:24:06     INFO -  /builds/worker/workspace/build/tests/xpcshell/head.js:_execute_test:522
[task 2018-05-30T14:24:06.449Z] 14:24:06     INFO -  -e:null:1
[task 2018-05-30T14:24:06.451Z] 14:24:06     INFO -  exiting test
[task 2018-05-30T14:24:06.451Z] 14:24:06     INFO -  PID 14275 | JavaScript error: /builds/worker/workspace/build/tests/xpcshell/head.js, line 731: NS_ERROR_ABORT:
[task 2018-05-30T14:24:06.453Z] 14:24:06     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "NS_ERROR_ABORT: " {file: "/builds/worker/workspace/build/tests/xpcshell/head.js" line: 731}]"
[task 2018-05-30T14:24:06.453Z] 14:24:06     INFO -  <<<<<<<
Assignee: nobody → daniel
Priority: P5 → P3
Whiteboard: [necko-triaged]
We are trying to build a tool to automatically classify intermittent failures, which would provide a starting point for fixing the bug, reducing the manual work for the developers.
We are collecting some feedback on the results, to see if they’re good enough and where we need to improve.
    
For this bug, the tool says that the intermittent failure is most likely a:
Concurrency Issue: This includes tests in which failures occur due to thread management issues (different threads or their outcomes depending on an implicit ordering), race conditions and/or deadlocks, and issues related to an asynchronous waits (e.g. a process trying to access an external resource or continuing before the external resource is available).


Once you’re done investigating and/or fixing the bug, could you tell me:
- Did the tool correctly recognize the type of intermittent failure?
- Did the information from the tool help your analysis, the bug fixing process, or anything in the process? (please also let us know how the tool was useful and/or what would improve the tool's usefulness for you)
Flags: needinfo?(daniel)
Summary: Intermittent netwerk/test/unit/test_trr.js | onLookupComplete - [onLookupComplete : 147] false == true → Intermittent netwerk/test/unit/test_trr.js | onLookupComplete - [onLookupComplete : 148] false == true
Priority: P3 → P1
Flags: needinfo?(daniel)
See Also: → 1444695
These are two very similar test failures that keep triggering but irregularly and rarely. I've never been able to reproduce these problems locally.

Both bugs are failures to get an AAAA response from the TRR h2 test server.
Assignee: daniel → nobody
Priority: P1 → P2
See Also: → 1540656
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1542561
You need to log in before you can comment on or make changes to this bug.