When user delete an url from the address bar with "delete" key, url in the addresse bar should change accordingly

RESOLVED WORKSFORME

Status

()

defect
P2
normal
RESOLVED WORKSFORME
Last year
6 days ago

People

(Reporter: clement.lefevre, Unassigned)

Tracking

({nightly-community, privacy})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozfr-community][fxsearch])

Attachments

(1 attachment)

Reporter

Description

Last year
As of now, when user delete the currently selected URL in the address bar from the history with the "delete" key, URL bar keeps that URL even if the selection moved to the below URL.
Address bar's url should be updated accordingly to reflect the currently selected URL after deletion.

See joined video for an exemple.
Reporter

Updated

Last year
Whiteboard: [mozfr-community]
Ugh, I wonder if this is a regression...
I'm sure we have another bug where DELETE + Enter could still visit the deleted url. Though IIRC the input field was updated...
Keywords: privacy
Priority: -- → P2
Whiteboard: [mozfr-community] → [mozfr-community][fxsearch]
Reporter

Comment 2

Last year
(In reply to Marco Bonardo [::mak] from comment #1)
> Ugh, I wonder if this is a regression...
> I'm sure we have another bug where DELETE + Enter could still visit the
> deleted url. Though IIRC the input field was updated...

This looks like a very similar issue, the only difference being that you were seeing an update?
Note: this only happens if you've done a partial typed entry in the url. If you just down arrow to begin with the text updates correctly straight away.

WFM in Nightly with Quantum Bar enabled

Status: NEW → RESOLVED
Closed: 6 days ago
Resolution: --- → WORKSFORME
Reporter

Comment 5

6 days ago

(In reply to Marco Bonardo [::mak] from comment #4)

WFM in Nightly with Quantum Bar enabled

Just tested right now, I don't know how you can say it does work, as here it's working even less than when I filed the bug: hitting delete doesn't remove the url from history anymore, let alone update the urlbar :/

Don't know if I should reopen here though as bug is probably linked but not the same?

EDIT: Tested in nightly. In stable, behavior is the same as when I opened the bug.

Flags: needinfo?(mak77)

You now need to use shift-delete to delete an entry. This was an intentional change for various reasons.

Flags: needinfo?(mak77) → needinfo?(clement.lefevre)
Reporter

Comment 7

6 days ago

Okay, so this is indeed fixed by using shift to delete.
For my information, why was it decided to add shift now? I discovered the delete shortcut for this by myself; shift + delete is probably impossible to discover yourself as compared to only delete.

Flags: needinfo?(clement.lefevre)

because we are soon keeping the popup open more often when the user is typing and modifying the input text, thus it makes more sense for DEL to act on the text in the input field, it would be confusing if it would have 2 different functions. It was possible in the past because the popup was closed at every cursor movement.

You need to log in before you can comment on or make changes to this bug.