nsBoxFrame::RemoveFrame triggered nsContainerBox::SanityCheck

VERIFIED DUPLICATE of bug 145792

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 145792
16 years ago
10 years ago

People

(Reporter: timeless, Assigned: David Hyatt)

Tracking

({assertion})

Trunk
x86
Windows 2000
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
###!!! ASSERTION: nsBox::ERROR!! Box info list count does not match frame 
count!!: 'length == mChildCount', file 
F:\build\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 412
mchilddcount was 0, mlength was 1.

I had opened in order:
navigator [launched]
mailnews [quit before problem]
downloadmanager [it asserted while i tried to load an ftp link to openwatcom's 
source -- bug filed]
composer [quit before problem]
addressbook
(Reporter)

Comment 1

16 years ago
Created attachment 84850 [details]
stack + jsstack
(Reporter)

Comment 2

16 years ago
it appears i triggered the address book search window
Keywords: assertion
Summary: nsBoxFrame::RemoveFrame triggered nsContainerBox::SanityCheck → nsBoxFrame::RemoveFrame triggered nsContainerBox::SanityCheck

Comment 3

16 years ago
Yes, the search messages window asserts. I reported this earlier this week.

*** This bug has been marked as a duplicate of 145792 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.