Status

()

defect
RESOLVED DUPLICATE of bug 1473041
a year ago
11 months ago

People

(Reporter: vicenzi.alexandre, Unassigned)

Tracking

({fonts, regression})

Trunk
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox-esr60 wontfix, firefox60 wontfix, firefox61 fix-optional, firefox62 fix-optional, firefox63 fix-optional)

Details

()

Attachments

(1 attachment)

Reporter

Description

a year ago
Posted image font-error.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180531101452

Steps to reproduce:

Visit https://www.futureportprague.com/

Take a closer look at the nav menu.
There's an image attached to show the problem.



Actual results:

The font is not smooth, there are lines over the characters.
Looks like it's not drawing properly.


Expected results:

The font should be smooth.

*

The problem is not the font or some CSS.
Looks like this only happens inside tag <ul> or <li>, others elements are not affected.

I can reproduce this on Firefox Stable and Nightly.
I'm running Ubuntu 18 with Gnome.
Reporter

Updated

a year ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Reporter

Comment 1

a year ago
I can't reproduce on Windows 10.

Updated

a year ago
Has STR: --- → yes
Component: Untriaged → Graphics: Text
Keywords: fonts
Product: Firefox → Core
Markus, this seems like it might be a case with layerization where something that should be disabling subpixel AA is not? Ideas?
Flags: needinfo?(mstange)

Comment 3

a year ago
Reproduced in 60.0.1 (64-bit), Ubuntu.

Comment 4

a year ago
I can also reproduce the issue on win10 Nightly62.0a1 x64 if HWA is disabled.
OS: Linux → All

Comment 5

a year ago
Regression window on Windows:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=024e7dc7a219e3f276bc2245746bbad67a574ea9&tochange=209072396aa5ab5c5a0a28109a980dbbcd884922

Regressed  by: 209072396aa5	Mason Chang — Bug 1007702. Enable skia on unaccelerated windows. r=lsalzman


Regression window on Linux:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=01748a2b1a463f24efd9cd8abad9ccfd76b037b8&tochange=a551f534773cf2d6933f78ce7d82a7a33a99643e

Regressed  by: d0910ce4cff8	Lee Salzman — Bug 1278957 - enable Skia content for Linux and Android. r=mchang
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(mstange)
Resolution: --- → DUPLICATE
Duplicate of bug: 1473041
You need to log in before you can comment on or make changes to this bug.