crash when deleting quote webpage in html reply

VERIFIED DUPLICATE of bug 141054

Status

MailNews Core
Composition
--
critical
VERIFIED DUPLICATE of bug 141054
16 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Jean-Francois Ducarroz)

Tracking

(Blocks: 1 bug, {crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

martinl tells he has been hitting this crash frequently:

"Received email message containing a webpage. Was replying to the message, 
selected the quoted webpage, crashed when I hit the delete key."

reminds be of bug #141054, but the stack is different.

from talkback, here's his stack:

BuildFramechangeList 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5260]
WalkFramesThroughPlaceholders 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5310]
WalkFramesThroughPlaceholders 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5336]
WalkFramesThroughPlaceholders 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5336]
WalkFramesThroughPlaceholders 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5336]
WalkFramesThroughPlaceholders 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5336]
WalkFramesThroughPlaceholders 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5336]
WalkFramesThroughPlaceholders 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5336]
WalkFramesThroughPlaceholders 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5336]
PresShell::ReconstructStyleData 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5374]
PresShell::StyleSheetRemoved 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5428]
nsDocument::RemoveStyleSheet 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 1390]
nsStyleLinkElement::UpdateStyleSheet 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleLinkElement.cpp, line 181]
nsHTMLLinkElement::SetDocument 
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLLinkElement.cpp, 
line 111]
nsGenericElement::SetDocumentInChildrenOf 
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1421]
nsGenericElement::SetDocument 
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1488]
nsGenericHTMLElement::SetDocument 
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp, 
line 1270]
nsGenericHTMLContainerElement::RemoveChildAt 
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp, 
line 4094]
nsGenericElement::doRemoveChild 
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 2557]
nsHTMLOptionElement::RemoveChild 
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLOptionElement.cpp]
DeleteElementTxn::DoTransaction 
[d:\builds\seamonkey\mozilla\editor\libeditor\base\DeleteElementTxn.cpp, line 
112]
nsTransactionItem::DoTransaction 
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionItem.cpp, line 183]
nsTransactionManager::BeginTransaction 
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 
1078]
nsTransactionManager::DoTransaction 
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 
140]
nsEditor::Do [d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp, 
line 494]
nsEditor::DeleteNode 
[d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp, line 1304]
nsHTMLEditRules::DeleteNonTableElements 
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditRules.cpp, line 
2576]
nsHTMLEditRules::WillDeleteSelection 
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditRules.cpp, line 
2238]
nsHTMLEditRules::WillDoAction 
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditRules.cpp, line 
486]
nsPlaintextEditor::DeleteSelection 
[d:\builds\seamonkey\mozilla\editor\libeditor\text\nsPlaintextEditor.cpp, line 
938]
nsHTMLEditorLog::DeleteSelection 
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditorLog.cpp, line 
159]
nsTextEditorKeyListener::KeyPress 
[d:\builds\seamonkey\mozilla\editor\libeditor\text\nsEditorEventListeners.cpp, 
line 255]
nsEventListenerManager::HandleEvent 
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, 
line 1654]
nsDocument::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 3285]
nsGenericElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1687]
PresShell::HandleEventInternal 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6105]
PresShell::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6028]
nsViewManager::HandleEvent 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2030]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 306]
nsViewManager::DispatchEvent 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1887]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 869]
nsWindow::DispatchWindowEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 886]
nsWindow::DispatchKeyEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2660]
nsWindow::OnChar [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, 
line 2810]
nsWindow::ProcessMessage 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3459]
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1131]
USER32.DLL + 0x1b60 (0x77e11b60)
USER32.DLL + 0x1cca (0x77e11cca)
USER32.DLL + 0x83f1 (0x77e183f1)
nsAppShellService::Run 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 451]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1473]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1808]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1826]
WinMainCRTStartup()
KERNEL32.DLL + 0xd326 (0x77e8d326)
martin, do you have a particular email that you can easily reproduce this crash?
Keywords: crash
Nevertheless, probably the same as bug 141054.
Keywords: crash
Keywords: crash

Updated

16 years ago
Severity: normal → critical

Comment 3

16 years ago
To reproduce:

- Browse to this URL: http://www.wired.com/news/technology/0,1282,52703,00.html

- File/Send Page    (mail it to yourself)
- Have your mail prefs set to "Automatically quote the original message when
replying"
- Open message, click "Reply"
- In the reply window, select everything below the URL (select the divider line
and the web page)
- Hit the delete (backspace) key.

Comment 4

16 years ago
I cann't reproduce it. I tested on Solaris 8 with the URL:
http://www.wired.com/news/technology/0,1282,52703,00.html. I tested both
deleting the whole page or part of it. So, I think it should have the same
reason as bug 141054. If it can't be reproduced, let's close it.

dbaron, what's your opinion?

*** This bug has been marked as a duplicate of 141054 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.