Closed Bug 1466295 Opened 4 years ago Closed 4 years ago

Global Shortcuts not working in Firefox on Wayland in fedora27

Categories

(Core :: Widget: Gtk, defect)

60 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: yashladhapankajladha123, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180525140601

Steps to reproduce:

Installing the new firefox on fedora 27 which is ported to wayland.


Actual results:

The key shortcuts like Copy and Paste only works in firefox and not apps outside of firefox.


Expected results:

The shortcuts should work correctly and there should be no glitch.
Summary: Global Shortcuts not working on Firefox on Wayland in fedora27 → Global Shortcuts not working in Firefox on Wayland in fedora27
This issue seems to be a clipboard issue as well, so maybe a dupe after bug 1467132 ? 
Meanwhile as an initial triage blocking the Wayland metabug and setting the component.
Blocks: wayland
Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
Reporter, do you run firefox-wayland package, right? If so can you please describe your test case, which shortcuts fails and how? Thanks.
Flags: needinfo?(yashladhapankajladha123)
Should be fixed now.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.