CSS styles are not applied

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Raphael Goubet, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

When viewing my personal web page, the styles from the external CSS stylesheet
are not applied. This does not happen with any other browser (including Netscape
6.2), nor with Mozilla when viewing the pages localy. The font should be arial,
and the left column should be displayed in blue background. Links should be
styled, too.


Reproducible: Always
Steps to Reproduce:
Just load the page.

Actual Results:  Page is not displayed properly.

Expected Results:  See description.

Here is the content of the stylesheet:

body {  font-family: Arial, Helvetica, sans-serif; background-color: #FFFFFF}
body.home {  background-image: url(penseur.jpg); background-repeat: no-repeat;
background-position: center center; background-attachment: fixed}
a.white {  font-weight: bold; color: #FFFFFF; text-decoration: none}
a:hover {text-decoration: underline}
a:active {  color: #CCFFFF}
td.col { font-weight: bold; color: #FFFFFF; background-color: #9999FF }
td.smallfont {  font-size: smaller}
a.white:visited { color: #CCFFFF }
-> invalid

The server sends the wrong mime-type for the CSS

--06:59:56--  http://www.comu.ucl.ac.be/Doctorants/Goubet/styles.css
           => `styles.css'
Resolving www.comu.ucl.ac.be... done.
Connecting to www.comu.ucl.ac.be[130.104.187.147]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 566 [text/html]

text/html is wrong, it should be text/css
Mozilla ignores this Style file if you use a valid Doc Type.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
VERIFIED INVALID

Please send CSS stylesheets as text/css. Since Mozilla does not support
text/html stylesheets, it is ignoring the file in this case.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.