privacy.resistFingerprinting set to true breaks Proxy Switcher and Manager

RESOLVED DUPLICATE of bug 1412961

Status

()

defect
RESOLVED DUPLICATE of bug 1412961
Last year
Last year

People

(Reporter: rauchwolke, Unassigned)

Tracking

60 Branch
Points:
---

Firefox Tracking Flags

(firefox-esr60 affected, firefox60 affected, firefox61 unaffected, firefox62 unaffected)

Details

(Whiteboard: [fingerprinting-breakage])

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180503143129

Steps to reproduce:

* install Proxy Switcher and Manager Icon - https://addons.mozilla.org/en-US/firefox/addon/proxy-switcher-and-manager/
* set privacy.resistFingerprinting to true
* restart firefox





Actual results:

the toolbar icon is broken, there is a rectangle box instead of an icon

The bug is confirmed at github: https://github.com/rNeomy/proxy-switcher/issues/52 and the dev means this is a firefox bug as this setting shouldn't effect addons


Expected results:

the icon should be painted without a problem
Does this still happen on Nightly now that Bug 1453916 landed?
Flags: needinfo?(rauchwolke)
See Also: → 1453916
Whiteboard: [fingerprinting-breakage]
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0 
Build ID: 20180503143129   
I manage to reproduce this issue on Ubuntu 16.04 x64 with the latest FF 60.0 (64bit). Please note that this issue is not displayed on the latest FF Nightly.
Status: UNCONFIRMED → NEW
Component: Untriaged → Canvas: 2D
Ever confirmed: true
Product: Firefox → Core
That means bug 1412961 fixed it (and we have no intention to uplift this to release).
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(rauchwolke)
Resolution: --- → DUPLICATE
Duplicate of bug: 1412961
You need to log in before you can comment on or make changes to this bug.