Mozilla crashes on closing re-opened DeskTop-On-Call (DTOC) session

RESOLVED INVALID

Status

SeaMonkey
UI Design
--
critical
RESOLVED INVALID
16 years ago
11 years ago

People

(Reporter: Max Alekseyev, Assigned: jag (Peter Annema))

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: l: Mozilla p: Mozilla, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.0.0+) Gecko/20020523
BuildID:    2002052308

Mozilla crashes on closing DeskTop-On-Call 5.0 remote control window by pressing
"close" button (in the menu at right).

05-24-2002  01:03:17  SYS3175  PID 016b  TID 0001  Slot 006b
E:\INTERNET\MOZILLA\MOZILLA.EXE
c0000005
10101010
P1=00000001  P2=10101010  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00ee7178  EBX=10101010  ECX=00000003  EDX=01094c10
ESI=001307e4  EDI=003493c8  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:10101010  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:001305d0  SSACC=f0f3  SSLIM=ffffffff
EBP=00ee7178  FLG=00212202



Reproducible: Always
Steps to Reproduce:
1. Login to DTOC server
2. Open remote control window
3. Click on "Close remote control window" button in the menu.

Updated

16 years ago
Keywords: crash
(Reporter)

Comment 1

16 years ago
Evaluation version of DTOC 5.0 is available here:
ftp://ftp.jp.ibm.com/pub/pspj/dtoc/eval5e/

Comment 2

16 years ago
Ths info I have so far points to this being a Java problem.

It fails with 1.3.1 on Windows, but succeeds with 1.4, so I am not sure we can 
fix this on OS.2 since we don't have 1.4.

I'm continuing to investigate.
(Reporter)

Comment 3

16 years ago
Another crash related to DTOC:
If remote control window is closed by Close in system menu, then Mozilla
survives. But then it crashes on attempt to reconnect to DTOC server.
(Reporter)

Comment 4

16 years ago
In build 2002071608 Close button works fine for the first DTOC session. But
subsequent attempt to re-open the session for the second time and close it
causes a trap in MOZJS.DLL

So, it doesn't seem to be a Java problem.

I've added word "re-opened" to the summary.
Summary: Mozilla crashes on closing DeskTop-On-Call (DTOC) session → Mozilla crashes on closing re-opened DeskTop-On-Call (DTOC) session
(Reporter)

Comment 5

16 years ago
Linux build 2002072221 has the same problem. JRE 1.3.1
Sometimes it crashes on re-logon to DTOC server.

OS: OS/2 -> All
OS: OS/2 → All

Comment 6

16 years ago
*** Bug 176200 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Whiteboard: l: Mozilla p: Mozilla
(Reporter)

Comment 7

16 years ago
To http://bugzilla.mozilla.org/show_bug.cgi?id=176200#c3

Michael, I periodically see Mozilla crashes related to DTOC with the latest JRE
version 1.3.1 available from IBM. Or didn't you mean later not-yet-released version?

Comment 8

16 years ago
I mean a Java that won't exist on OS/2.
(Reporter)

Comment 9

16 years ago
We're waiting for JRE 1.4:
http://www.goldencode.com/company/press/20020814.html

Comment 10

16 years ago
Well intressting is that in Windows with MS IE Explorer this problem does not appear even that i only habe JAVA 1.3 installed.

Also the idle timeout will not hang up MS IE, only Mozilla :(

Also Mozilla for OS/2 works (opening control window) if no other program eg.PMCRC32.EXE is running.

If it is running (just be open and idle) Mozilla os/2 crashes with given POPUPLOG.OS2 entrys.

I am using latest JAVA 1.3.1 build aviable on www.ecomstation.com.

However when idle timeout is happening Mozilla hang up and need to be killed - same as in Windows.

The old Netscape 4.61 build for OS/2 works nicly and doesnt show this problem even when this PMCRC32.EXE program is running.

PMCRC32.ZIP is aviable on hobbes.

http://hobbes.nmsu.edu/pub/os2/util/misc/pmcrc32-20.zip

Comment 11

16 years ago
Addtional COmments to my previous one :

It seems not only PMCRCR32 is the problem alone.

It doesnt matter witch program is running, mozilla seems to crash all the time one the first time when the COntrol Window is appearing.

If you re-open mozilla and retry it after the crash it works then as it should.
(No crashes and you can control the other system thru Mozilla)


This crash problem only happens on OS/2 Mozilla.

If you connect to an OS/2 DOC V5 site using Windows Mozilla you dont get any crashes by opening the control Window.

However as already reported Windows Mozilla freezes when it disconnected by idle timeout.

I have not tried so far whats happening when using OS/2 Mozilla for an OS/2 DOC V5 site  - if mozilla still crashes or not.



Comment 12

16 years ago
You keep saying "crash"

Does it actually give a trap screen or just go away?

Comment 13

16 years ago
With crashes i mean only mozilla will be closed.

OS/2 will give out : (taken from Popuplog.os2)

11-19-2002  18:45:42  SYS3175  PID 009f  TID 0001  Slot 00e1
C:\MOZILLA\BIN\MOZILLA.EXE
c0000005
1d14dc59
P1=00000001  P2=322f2f66  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=009a3d14  EBX=00000000  ECX=322f2f3a  EDX=00131220
ESI=00000000  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1d14dc59  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00131208  SSACC=f0f3  SSLIM=ffffffff
EBP=00131228  FLG=00212206

OJI.DLL 0001:0000dc59


OS/2 itself will not trap nor having any other problems like - WPS freezes or 
so.

The WPS will only freeze if you get idle timeout from the DOC site.
(In Windows it freezes too but can be killed - in OS/2 it must be killed via watchcat since no WPS funtion is working and the Window list will not appear.


i am using yesterday's dialy night build of mozilla for os/2 and Java 1.3.1 ? from ecomstation web site.

FP#2 installed, and kernel is 14.81W4

(Reporter)

Comment 14

16 years ago
I've just got Linux build 2002120608 crash. JRE 1.4.0-02
Talkback ID: TB14843801K
Whiteboard: l: Mozilla p: Mozilla → TB14843801K // l: Mozilla p: Mozilla
(Reporter)

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 15

15 years ago
Well now Mozilla/Firebird works fine with Desktop on Call as long as it is the
first time calling the URL. (Tested with Java 1.3.1)

There is still a problem when connecting a 2nd time to the DOC Server - at least
mozilla doesnt crash anymore - but it will not open the 2nd control window.

Instead , Mozilla just idle and do nothing (but doesnt block or freeze).

Opening a 2nd instance of Mozilla doesnt work even , Mozilla must be completly
closed and restarted to get it working with a DOC server again.

Any chance to get it ever fully working ?



(Reporter)

Updated

15 years ago
Depends on: 225145

Updated

14 years ago
Whiteboard: TB14843801K // l: Mozilla p: Mozilla → l: Mozilla p: Mozilla
Product: Core → Mozilla Application Suite

Comment 16

12 years ago
Works?
Shouldn't this be marked OS/2 only?

(bug 225145 is marked works)
Assignee: samir_bugzilla → jag
QA Contact: pawyskoczka
(Reporter)

Comment 17

11 years ago
I have no access to DToC anymore. So I cannot test if the bug is still actual.

Comment 18

11 years ago
IBM doesn't even do DTOC anymore.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.