bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Profile names with space will sometimes disappear from profile manager



Startup & Profiles
16 years ago
14 years ago


(Reporter: Mikko Virkkilä, Assigned: Ben Goodger (use ben at mozilla dot org for email))


Firefox Tracking Flags

(Not tracked)




16 years ago
You can create and use profiles with spaces in the name, eg. "No Java". When you
don't completely restart your browser, these will be correctly shown in the
profile manager. However, the first time you close all your current mozilla
windows, and start mozilla again, the profiles with spaces will not be listed in
your profile manager, hence you will be unable to start those profiles. 

The profiles still exist, and if you chose to create a profile with exactly the
same name as earlier (with spaces and all) the profile will get listed (for that
session) in the profile manager, and you'll be able to use the settings from the

This is really irritating bug, since before I recognized it for what it was I
was always creating new profiles with names that had spaces, only to notice that
 next time I start mozilla they are no longer there. 

In short, this is how to reproduce it:
1) Start mozilla.
2) Create a new profile with the name "Look Here"
3) Close mozilla
4) Start mozilla (and profile manager)

The profile "Look Here" will not be listed, but it still exists on your HD.

Comment 1

16 years ago
WFM, current trunk CVS, Linux.

How are you starting "mozilla (and profile manager)" ?
Please also include build ID

Comment 2

16 years ago
I start mozilla just by running the ./mozilla script (well, I actually made an
icon on my desktop to the script).As I have more than one profile, my profile
manager pops up, so that I can chose which profile to use.

My build id is 2002052309 (RC3 but I remember seeing it also with RC2).

I Have not tested this with only one profile (i.e. only a "look here" profile)
since I always use several profiles. When you tested it, did you have "normal"
profiles besides the "Look Here" profile?

Comment 3

16 years ago
I cleaned out my old profiles (perhaps some recidues from 0.9.9 messed it up)
and I'm no longer able to reproduce this bug. 
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
Verified WFM

Comment 5

16 years ago
I updated my browser to 1.0 and lost all profiles which had spaces in them. 

I cannot always reproduce this, but there is a bug in there somewhere. Reopening
and updating summary.
Resolution: WORKSFORME → ---
Summary: Profile names with space will not get shown → Profile names with space will sometimes disappear

Comment 6

16 years ago
I noticed that the profile with the space only disappears after I have once
closed all mozilla windows (closing mozilla completely). Leaving just one window
open (of any user) and starting the profilemanager (by running ./mozilla) will
keep the profile with the space in the list.

This bug might be somehow related to bug 51509 and bug 148537

Probably related to bug 139562 and bug 151000

Summary: Profile names with space will sometimes disappear → Profile names with space will sometimes disappear from profile manager

Comment 7

16 years ago
It WORKSFORME with Moz1.1b On Linux
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Following the steps of the original description, I was able to see and use the
"Look Here" profile even after completely quitting and restarting mozilla. On a
side note, I am not so sure that this bug is related to bug 151000 because that
one only seems to occur when several instances of mozilla are running at the
same time.

Comment 8

16 years ago
Mikko, would you mind testing this with a recent version of mozilla and seeing
if you can still reproduce it?
no answer
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.