If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

zvon.org - XSLT not working due to wrong HTML namespace

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Czech
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Markus Hübner, Unassigned)

Tracking

Details

(Whiteboard: [bug248549notfixed], URL)

(Reporter)

Description

16 years ago
using latest trunk build 2002052
the transformation is not working - just the xml being displayed.

works fine with branch build 2002052306
Strange behaviour. 'Transferring data from zvon.org', but I don't get any screen
output. But sourcecode is being transferred...

2002052306/Win2k SP2

Comment 2

16 years ago
the zvon stylesheet uses a namespace, which is not a namespace. XSLT does 
exactly the right thing. We generate the elements in the specified namespace,
but this just ain't XHTML. And HTML would be *no* namespace.
This is an evang issue.
Getting rid of the xmlns="http://www.w3.org/TR/REC-html40" might be enough to 
fix the display, but the html:script tags need to be in the right namespace,
too.
"http://www.w3.org/1999/xhtml" is the one.
Assignee: peterv → piskozub
Component: XSLT → Europe: Central
Product: Browser → Tech Evangelism
QA Contact: keith → pali
Summary: XSLT not workign on zvon.org → XSLT not working on zvon.org due to wrong HTML namespace
Version: other → unspecified
(Reporter)

Comment 3

16 years ago
What is curious though is that the site works perfectly with the 1.0 branch 
build.

Comment 4

16 years ago
bug 134278 makes the difference between trunk and branch. That checkin removed
"http://www.w3.org/TR/REC-html40"

Comment 5

16 years ago
This is Czech site in the end... I'll investigate it in a week. (I'm currently
busy getting married)
Assignee: piskozub → pali
QA Contact: pali → piskozub
Summary: XSLT not working on zvon.org due to wrong HTML namespace → zvon.org - XSLT not working due to wrong HTML namespace

Comment 6

15 years ago
> cz
Component: Europe: Central → Czech

Comment 7

14 years ago
WFM?
Assignee: pali → czech
QA Contact: piskozub → czech
Only XML in browser with the following error message: "This XML file does not
appear to have any style information associated with it. The document tree is
shown below."

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1
The url is not to the styled page, but to the stylesheet itself (xslt stylesheet
in this case). I couldn't immediatly find a url that used XSLT, if someone can
please add it here.

They still seem to be using the wrong namespace in some cases though. However
they are sending the page as text/html which means that we won't treat it as
namespaced XML at all.

I gotta say, it's pretty sad to see a site that claims to be good at, even
teaching, XML screwing things up so badly.

Updated

13 years ago
Whiteboard: [bug248549notfixed]

Comment 10

7 years ago
A slightly munged version is also at
  http://web.archive.org/web/20041107223324/http://www.zvon.org/o_xml_xslt/style_xml.xslt
I cant find the page which used it.
Problem not found
Mozilla/5.0 (Android; Mobile; rv:23.0) Gecko/23.0 Firefox/23.0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.