Closed Bug 1466931 Opened 3 years ago Closed 3 years ago

Perma Jittest failures on wasm/binary.js when Gecko 62 merges to Beta on 14-06-2018

Categories

(Core :: Javascript: WebAssembly, defect)

defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed
firefox62 + verified

People

(Reporter: CosminS, Assigned: lth)

References

Details

Attachments

(1 file)

Central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&revision=94f89908021275cc63f98e3111249000ecf74c97&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable&filter-searchStr=jit

Failure log: [task 2018-06-05T17:05:16.518Z] 17:05:16  WARNING -  TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/wasm/binary.js | /builds/worker/workspace/build/tests/jit-test/jit-test/lib/asserts.js:78:27 Error: Assertion failed: expected /unrecognized opcode/, got at offset 23: popping value from empty stack (code 3, args "") [0.3 s]
[task 2018-06-05T17:05:16.518Z] 17:05:16     INFO -  {"action": "test_start", "jitflags": "", "pid": 14861, "source": "jittests", "test": "wasm/binary.js", "thread": "main", "time": 1528218316.241639}
[task 2018-06-05T17:05:16.519Z] 17:05:16     INFO -  {"action": "test_end", "extra": {"jitflags": "", "pid": 14861}, "jitflags": "", "message": "/builds/worker/workspace/build/tests/jit-test/jit-test/lib/asserts.js:78:27 Error: Assertion failed: expected /unrecognized opcode/, got at offset 23: popping value from empty stack", "pid": 14861, "source": "jittests", "status": "FAIL", "test": "wasm/binary.js", "thread": "main", "time": 1528218316.510314}
[task 2018-06-05T17:05:16.520Z] 17:05:16     INFO -  INFO exit-status     : 3
[task 2018-06-05T17:05:16.520Z] 17:05:16     INFO -  INFO timed-out       : False
[task 2018-06-05T17:05:16.521Z] 17:05:16     INFO -  INFO stderr         2> /builds/worker/workspace/build/tests/jit-test/jit-test/lib/asserts.js:78:27 Error: Assertion failed: expected /unrecognized opcode/, got at offset 23: popping value from empty stack
[task 2018-06-05T17:05:16.521Z] 17:05:16     INFO -  INFO stderr         2> Stack:
[task 2018-06-05T17:05:16.522Z] 17:05:16     INFO -  INFO stderr         2> assertErrorMessage@/builds/worker/workspace/build/tests/jit-test/jit-test/lib/asserts.js:78:27
[task 2018-06-05T17:05:16.522Z] 17:05:16     INFO -  INFO stderr         2> @/builds/worker/workspace/build/tests/jit-test/jit-test/tests/wasm/binary.js:471:5
[task 2018-06-05T17:05:17.885Z] 17:05:17     INFO -  /builds/worker/workspace/build/tests/jit-test/jit-test/lib/asserts.js:78:27 Error: Assertion failed: expected /unrecognized opcode/, got at offset 23: popping value from empty stack
[task 2018-06-05T17:05:17.886Z] 17:05:17     INFO -  Stack:
[task 2018-06-05T17:05:17.887Z] 17:05:17     INFO -    assertErrorMessage@/builds/worker/workspace/build/tests/jit-test/jit-test/lib/asserts.js:78:27
[task 2018-06-05T17:05:17.889Z] 17:05:17     INFO -    @/builds/worker/workspace/build/tests/jit-test/jit-test/tests/wasm/binary.js:471:5
[task 2018-06-05T17:05:17.890Z] 17:05:17     INFO -  Exit code: 3
[task 2018-06-05T17:05:17.891Z] 17:05:17     INFO -  FAIL - wasm/binary.js

This looks like a regression from 1429818 
https://hg.mozilla.org/mozilla-central/rev/df11dced021e
Flags: needinfo?(lhansen)
Will take care of this asap.
Assignee: nobody → lhansen
Flags: needinfo?(lhansen)
Attachment #8983730 - Flags: review?(jseward)
Comment on attachment 8983730 [details] [diff] [review]
bug1466931-remove-bad-guard.patch

Sounds plausible to me.
Attachment #8983730 - Flags: review?(jseward) → review+
Pushed by lhansen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8a4b9dd1d15e
Correctly identify the first invalid wasm opcode.  r=jseward
https://hg.mozilla.org/mozilla-central/rev/8a4b9dd1d15e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
No longer appears on recent beta simulations.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.