Closed Bug 1467035 Opened 2 years ago Closed 2 years ago

[Redstone5] On Windows 10 Insider Build (17682.100) when FireFox is minimized and maximized, it gains an invisible "Sets" titlebar which is transparent and can be clicked through

Categories

(Core :: Widget: Win32, defect, P2)

60 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- fixed
firefox60 --- wontfix
firefox61 - fixed
firefox62 + fixed

People

(Reporter: kvn95ss, Unassigned)

Details

Attachments

(1 file)

Attached image FF_bug.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180516032328

Steps to reproduce:

Open FireFox, minimize it then maximize it (number of tabs doesn't matter)

OS - Windows 10 Insider Build (17682.100)


Actual results:

When restoring the window, FF obtains a "Sets" style, transparent and click-through title bar.


Expected results:

FF should've been maximized normally.
i'm confirming this reports as it's an issue that's showing up a number of times in the support forum as well:
https://support.mozilla.org/en-US/questions/firefox?owner=all&tagged=bug1467035&show=all

not sure if it's our bug or one for msft to fix though...
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Gtk
Ever confirmed: true
Product: Firefox → Core
Component: Widget: Gtk → Widget: Win32
UPDATE 

The bug is due to Windows 10 Insider Preview. 

I went into Settings > System > Multi-tasking and below the section Sets there is an option to exempt apps from the disaster that is Sets labelled "Apps added to this list can't be included in sets of tabs".

I included FireFox to the list, and the problem no longer persists!

Spread the word!
Fx62 ships before the next Win10 update does, so I don't see see a need to track this for 61. I'll consider a low-risk patch for uplift if one materializes on the Firefox side of things, however.
Jim, what do you think about this issue? While there is a workaround in comment 2, if it's being reported often on SUMO we may want to try to fix the issue on our side, or contact Microsoft about the bug.
Flags: needinfo?(jmathies)
This is a work in progress build of Win10, pretty sure microsoft will fix this before they ship.

https://blogs.windows.com/windowsexperience/2018/05/31/announcing-windows-10-insider-preview-build-17682/
Flags: needinfo?(jmathies)
Priority: -- → P2
Summary: On Windows 10 Insider Build (17682.100) when FireFox is minimized and maximized, it gains an invisible "Sets" titlebar which is transparent and can be clicked through → [Redstone5] On Windows 10 Insider Build (17682.100) when FireFox is minimized and maximized, it gains an invisible "Sets" titlebar which is transparent and can be clicked through
It seems that the bug has been fixed on the Windows side, on their newest Insider Preview build 17723. 

I wasn't able to reproduce this problem using the steps provided in the bug description on latest Nightly 63.01 (2018-07-29) and Beta 62.0b12 (20180726161819).
I will close this as WFM per comment 6. Please reopen this, if the bug starts to occur again.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.