Closed Bug 1467130 Opened 2 years ago Closed 2 years ago

Bustages TrackBuffersManager.h:169:17: error: unused variable 'trackData' [-Werror=unused-variable] when Gecko 62 merges to Beta on 14-06-2018

Categories

(Core :: Audio/Video: Playback, defect)

62 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1466606
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 + fixed

People

(Reporter: NarcisB, Unassigned)

Details

Central as beta simulaton: https://treeherder.mozilla.org/#/jobs?repo=try&revision=3db4092d6ed1a2185dc8477b0537e737ef2e4ec2&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=runnable&filter-classifiedState=unclassified&selectedJob=182077726

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=182077726&repo=try&lineNumber=17747

Relevant log data:

[task 2018-06-06T12:56:47.902Z] 12:56:47     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/dom/SourceBuffer.h:27:0,
[task 2018-06-06T12:56:47.902Z] 12:56:47     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dom/bindings/SourceBufferBinding.cpp:18,
[task 2018-06-06T12:56:47.902Z] 12:56:47     INFO -                   from /builds/worker/workspace/build/src/obj-firefox/dom/bindings/UnifiedBindings19.cpp:122:
[task 2018-06-06T12:56:47.902Z] 12:56:47     INFO -  /builds/worker/workspace/build/src/obj-firefox/dist/include/TrackBuffersManager.h: In member function 'void mozilla::TrackBuffersManager::AssertHasNextSampleIndex(mozilla::TrackInfo::TrackType) const':
[task 2018-06-06T12:56:47.902Z] 12:56:47     INFO -  /builds/worker/workspace/build/src/obj-firefox/dist/include/TrackBuffersManager.h:169:17: error: unused variable 'trackData' [-Werror=unused-variable]
[task 2018-06-06T12:56:47.902Z] 12:56:47     INFO -       const auto& trackData = GetTracksData(aTrack);
[task 2018-06-06T12:56:47.903Z] 12:56:47     INFO -                   ^~~~~~~~~
[task 2018-06-06T12:56:47.903Z] 12:56:47     INFO -  cc1plus: all warnings being treated as errors
[task 2018-06-06T12:56:47.903Z] 12:56:47     INFO -  /builds/worker/workspace/build/src/config/rules.mk:1031: recipe for target 'UnifiedBindings19.i_o' failed
[task 2018-06-06T12:56:47.903Z] 12:56:47     INFO -  make[5]: *** [UnifiedBindings19.i_o] Error 1
[task 2018-06-06T12:56:47.903Z] 12:56:47     INFO -  make[5]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/dom/bindings'
[task 2018-06-06T12:56:47.903Z] 12:56:47     INFO -  make[5]: *** Waiting for unfinished jobs....

This is a regression from https://bugzilla.mozilla.org/show_bug.cgi?id=1466606
Flags: needinfo?(jyavenard)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jyavenard)
Resolution: --- → DUPLICATE
Duplicate of bug: 1466606
You need to log in before you can comment on or make changes to this bug.