Closed Bug 1467173 Opened 5 years ago Closed 3 years ago

Color boxes not are aligned in the Colors subdialog

Categories

(Firefox :: Settings UI, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- verified

People

(Reporter: asimonca, Assigned: Paolo)

References

Details

(Keywords: regression)

Attachments

(4 files)

[Affected versions]:
- Tested on Beta 61.0b11

[Affected platforms]:
- All

[Steps to reproduce]:
1. Navigate to about:preferences
2. Under "Language and Appearance" press the "Colors..." button

[Expected result]:
- The dialog looks correct

[Actual result]:
- The color boxes and the check box with the string "Underline links" are misaligned relative to text on the left side.

[Regression range]:
- This issue was introduced by the new localization API.
Can you provide more information please? I'm attaching a screenshot from today's nightly and while it looks slightly different from your screenshot, both seem aligned to me?
Flags: needinfo?(alexandru.simonca)
With gandalf's screenshot, using xScope's ruler, I can see the misalignment.
This doesn't look like it's fluent-related. Instead it's a regression from bug 1392517.
Priority: -- → P3
Summary: [Fluent] Color boxes not are aligned in the Colors subdialog → Color boxes not are aligned in the Colors subdialog
The situation is the same on both nightly and beta builds. They are only off by a few pixels, so we drew the straight lines to point this out.
Blocks: 1415730
No longer blocks: 1392517
Flags: needinfo?(alexandru.simonca)
Keywords: regression
Priority: P3 → --
Summary: Color boxes not are aligned in the Colors subdialog → [Fluent] Color boxes not are aligned in the Colors subdialog
Version: 61 Branch → Trunk
Summary: [Fluent] Color boxes not are aligned in the Colors subdialog → Color boxes not are aligned in the Colors subdialog
Blocks: 1392517
No longer blocks: 1415730
Keywords: regression
Priority: -- → P3
Attached image corrected_dialog

This seems corrected in the latest nightly; can someone confirm?

Assignee: nobody → paolo.mozmail
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1493844
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.