Closed Bug 1467212 Opened 2 years ago Closed 9 months ago

[meta] JS Actor APIs to replace FrameScripts for Fission

Categories

(Core :: DOM: Core & HTML, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Fission Milestone M4

People

(Reporter: relaas, Assigned: jdai)

References

(Blocks 2 open bugs)

Details

(Keywords: meta)

No description provided.
Thomas: Can we get details here?
Flags: needinfo?(telin)
Priority: -- → P3
Flags: needinfo?(telin)
Assignee: nobody → jdai
Priority: P3 → P2
Depends on: 1513876
Depends on: 1513877
Depends on: 1513878
Blocks: 1475415
No longer depends on: 1475415
Blocks: rm-docshell-tree-item
No longer blocks: browsingcontext
Depends on: 1523631
Fission Milestone: --- → M1
Fission Milestone: M1 → M2
Summary: Design and implement framescript replacement APIs on Abstract Browsing Context Trees → [meta] JS Actor APIs to replace FrameScripts for Fission
Depends on: 1526406

Can we please get the details in a publicly available document?

Flags: needinfo?(jdai)

(In reply to Tomislav Jovanovic :zombie from comment #3)

Can we please get the details in a publicly available document?

It would be nice to document at MDN or wiki after we finish.

Flags: needinfo?(jdai)

(In reply to John Dai[:jdai] from comment #2)

Fission JS IPC:
https://docs.google.com/document/d/1ALC8TxBy4pfS2tzI8Mb8Z3Nr5dzSjYYPSQxMn00_aWE/edit?ts=5bf786b3

I was referencing this (I'm assuming) design doc, are there reasons to keep engineering details non-public?

Flags: needinfo?(jdai)
Depends on: 1528387

(In reply to Tomislav Jovanovic :zombie from comment #5)

(In reply to John Dai[:jdai] from comment #2)

Fission JS IPC:
https://docs.google.com/document/d/1ALC8TxBy4pfS2tzI8Mb8Z3Nr5dzSjYYPSQxMn00_aWE/edit?ts=5bf786b3

I was referencing this (I'm assuming) design doc, are there reasons to keep engineering details non-public?

I believe we should go for the public, however, the design document which you reference isn't fully complete, the API's still changing slightly while we implementing. If you don't mind can you please wait for a while, once we finished all the API, we will update the design document as well. :)

Flags: needinfo?(jdai)
Depends on: 1531837
Duplicate of this bug: 1436504
Depends on: 1533401
Depends on: 1527753
Component: DOM → DOM: Core & HTML
Depends on: 1539147
Status: NEW → ASSIGNED
No longer depends on: 1532795
Fission Milestone: M2 → ---

Per John Dai, this is a meta bug and shouldn't be a part of the M2 milestone.

Depends on: 1550783
Depends on: 1550613
Depends on: 1552263
Depends on: 1552268
Depends on: 1552554
Depends on: 1553315
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

(In reply to John Dai[:jdai] from comment #6)

I believe we should go for the public, however, the design document which you reference isn't fully complete, the API's still changing slightly while we implementing. If you don't mind can you please wait for a while, once we finished all the API, we will update the design document as well. :)

Can we please get this published somewhere now that the bug was resolved as fixed?

Flags: needinfo?(jdai)
Duplicate of this bug: 1436569

(In reply to Tomislav Jovanovic :zombie from comment #9)

(In reply to John Dai[:jdai] from comment #6)

I believe we should go for the public, however, the design document which you reference isn't fully complete, the API's still changing slightly while we implementing. If you don't mind can you please wait for a while, once we finished all the API, we will update the design document as well. :)

Can we please get this published somewhere now that the bug was resolved as fixed?

I'm working on the document, file bug 1556686 for tracking, thanks for reminding me. :)

Flags: needinfo?(jdai)
Depends on: 1557486
Depends on: 1563597
Depends on: 1557852
Status: RESOLVED → REOPENED
Fission Milestone: --- → M5
Depends on: 1579536
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Fission Milestone: M5 → M4
Closed: 1 year ago9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.