Open Bug 1467291 Opened Last year Updated 5 months ago

Command line option fails

Categories

(Firefox :: Private Browsing, defect)

60 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

UNCONFIRMED

People

(Reporter: woutervalkering, Unassigned, NeedInfo)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180516032328

Steps to reproduce:

open cmd
go to firefox folder
type: firefox -private-window $URL



Actual results:

A new regular tab opened with $URL


Expected results:

A new private window/tab should've opened with $URL

I have tried:
- private-window "google.com"
- private window https://google.com
- private window URL google.com

and some other varieties, can't get it to work on W10. Most recent updated version.
(In reply to Wouter from comment #0)
> type: firefox -private-window $URL

That tries to open http://www.$url.com in a private window, which results in a Server Not Found error.
Is Firefox already running when you launch the command? If yes, is a private window already open?

> I have tried:
> - private-window "google.com"
> - private window https://google.com
> - private window URL google.com

-private-window https://google.com should work, with 2 hyphens and 0 spaces in the command line parameter.
-private-window google.com should also be fine.
Component: Untriaged → Startup and Profile System
OS: Unspecified → Windows 10
Product: Firefox → Toolkit
Hardware: Unspecified → x86_64
Component: Startup and Profile System → Private Browsing
Product: Toolkit → Firefox

The priority flag is not set for this bug.
:jdm, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(josh)
Flags: needinfo?(josh) → needinfo?(lcrouch)
You need to log in before you can comment on or make changes to this bug.