Having the plus sign in email address newsgroup account causes strange behaviour

VERIFIED DUPLICATE of bug 98664

Status

SeaMonkey
MailNews: Account Configuration
VERIFIED DUPLICATE of bug 98664
16 years ago
13 years ago

People

(Reporter: Ville Jorma, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
BuildID:    2002052306

user+detail@host.example type of email address in the email
field of a newsgroup account causes Mozilla to behave
strangely and eventually crash.

Reproducible: Always
Steps to Reproduce:
1. Create a newsgroup account named news.example.com with 
bug+test@host.example as the email address
2. Go to subscribe some newsgroups, subscribe to one
and exit the subcribe dialog.
3. Click the newly subscribed newsgroup


Actual Results:  Mozilla generates a new account named
bug%2Btest on news.example.

If you click that the or the original one, the same is
repeated infinitely.
Mozilla will crash eventually if you continue this.


Expected Results:  The download headers dialog should have appeared or the 
newsgroup
contents shown depending on the number of messages available in
the newsgroup in question.

This has been tested on Windows XP and Linux.
email accounts seems to function as expected with plus sign in
the email field.

Comment 1

16 years ago
Appears to be a duplicate of bug# 98664.

*** This bug has been marked as a duplicate of 98664 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup, it is.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.